iPad control ? v2.0


#1

Hello OpenROV world,

Curious if anyone is working on sorting out how to control the OpenROV with iPad... I've got the connection figured out with the wireless etc... but currently only have up and down for controls.

I imagine it could be controllable similar to the AR Drone with the tilt for speed, etc... but sadly for me that is imagination, as I don't have the skill set to 'make it so!"

I'm taking the OpenROV with me to meetings and presentations all around Seattle and that is a question/request I get a lot. I'm also personally interested as it will make it more feasible for getting out over CSO's and storm drains via Kayak.

:)


#2

Hey Laura,

We have early community contributed code that is shipping with the ROVs that has gamepad support that has been shown to work with both Ipads, Android, and touch enabled laptops. Some in the forum have confirmed that they have been using that setup.

You should be able to try it by surfing to the address of the rov like you do normally from a laptop.


#3

Hi Brian,

I am able to connect with an iPad 4 in the same way that the poster described with the wireless router TP Link (this takes a bit of tinkering, its not as straight forward as 'just fire it up').

I can see what the camera sees on my iPad. I have "up" and "down" control but the forward backward left and right controls don't work. I can see them, i can try sliding/touching/holding in the same way i'd fly a quad or play a game with my iPad, but they don't activate the motors on the ROV.

Laura


#4

Cool. I'll borrow my wife's IPAD mini tomorrow and see if I can recreate what you are experiencing. Do the laser and light buttons work for you?


#5

Cool!!!!!

Uh, hmm.... can't remember? I think so?


#6

So I am able to recreate the issue, which is good news. The bad news is that is will take a some time to troubleshoot the problem! If anyone wants to know when it gets fixes, subscribe to:


#7

Yay!


#8

Any updates? :slight_smile: We have a few demo days lined up and at least one expo, and it would be amazing to be able to use ipad/iphones :iphone:


#9

Hey Laura,
Sorry, the this issue is still in the hopper awaiting a free day on OpenROV to get worked on. It has not been forgotten, just shoved behind getting the auto-update bugs worked out.

-Brian


#10

I’ve been out of touch the the OpenROV community for some time now. Has any progress been made on this? I have similar problems as DiverLaura, where I can touch the up/down/light/laser buttons and get somewhat a response, but the drive commands aren’t working.

Perhaps there is a spot in the code you can point me to and I can try and hack something up myself? There is an ROV competition this weekend using the ROV in a Bag kit for middle schoolers, and I was going to bring the OpenROV to demonstrate and let them drive it using my iPad in a LifeProof case.

Thanks!


#11

Pull Request are always welcome.

Just a couple notes. I know that the Chrome team has been making changes to the touch control APIs to normalize them with Firefox and everyone else. It is possible that the helper library we are using is now obsolete. The library is here:

This is the file that hold the configuration for the touch controls:
https://github.com/OpenROV/openrov-software/blob/master/src/plugins/touchcontroller/public/js/touchcontroller.js

Our copy of the library is found here:
https://github.com/OpenROV/openrov-software/blob/master/src/plugins/touchcontroller/public/js/gamecontroller.js


#12

I know it’s been a long time, but has this issued been resolved? I normally fly using my laptop, but I am giving a poster presentation on my OpenExplorer project at a university conference this week and intend to run a live feed from the ROV to an iPad mounted directly to the poster. It would be nice to have full functionality for the wow factor

Edit: I see on the GitHub page that this functionality is being implemented for the Trident, so I take it it’s not being addressed for v2.8?


#13

Mobile control is being worked on right now. We are working on an overhaul of the entire mobile system to be released with the next software update for the 2 Series.

Most of the software will be cross platform for both the 2 Series and Trident.