Initial connection to the laptop


#1

Could use some pointers on getting the Kit connected to the laptop the first time.

In order to verify everything works before wiring it in to the case, I got hold of a 12V power supply and have everything laid out on a bench.

Note, if the Red SPI IF led goes off on the cape it appears to indicate low current. The electronics appear to be pulling .11A just sitting with network plugged in.

So now I have all green lights. I am using a cross-over cable to connect the bb+cape to my Mac's gigabit port. I have one green and one yellow light on the bb NIC. I have also confirmed that the 12/2 build of the software is loaded on the SD card in the bb.

I only have the LEDs, Camera, case servo attached at the moment.

I have set my NIC on the laptop to a manual IP of 192.168.254.2. It is my understanding from the the software readme that the bb should be listening to 192.168.254.1 regardless of the availability of DHCP for an address.

Yet my pings from the laptop are failing and I am unable to browse http://192.168.254.1:8080/


#2

I suggest that you check the cross-over cable or re-image the SD card. Plug the bone into your router and see if it pings when using DHCP?

I am in a similar situation here but with different problems. Mine was only staying connected for 00:05:06 then dropping the connection. I changed my sd card out and that problem has resolved itself.

What is LED3 on the cape indicate? Mine is RED? Well, for that matter, is there a list of each LED and it's significance? Someone please tell me before I get knee deep in code figuring it out for myself :)


#3

Thanks. I'm not having any luck with it directly connected to the router either. I'm going to try re-imaging in the SD card... and if that does not work I'll load the drivers so that I can attempt to see if I can connect via the USB card directly to the bb.


#4

Yep. That did it with the re-image. Go figure. For those using OS/X, I simply downloaded the .img file referenced for the instructions for using Windows and followed these instructions to image it.


#5

I'm at the same stage, testing using the twisted pair and the two ETS baluns. Once powered up, the Beagle shows a double flashing green at 0 and a single solid green next to the black plug. The bb NIC has the yellow and green.

I've tested via router and direct to Mac, no ping, no connection in Chrome and FF. Here is a close up (in focus even) of the board powered up. LED leads removed for clarity.

bb test power up


#6

Did you try either of the other two graphical interface options?


#7

I had the same problem with the SD card image coming with the kit. I could not connect to the beaglebone via ethernet neither through my router (dynamical IP address via DHCP) nor by direct connection (assuming beaglebone has static IP address 192.168.254.1).

Writing the SD card image again (I did it with the Windows solution described here) did the job.


#8

Here is a description of the LED indicator lights on the board.

In short, once powered up, 0 gives a heartbeat double flash, 1 shows SD card read, (mine does a quick couple of flashes on powerup.)

Click though here for my board powered up with notes


#9

I have tried the OSX RPi-SD card builder app to write the SD card image again. Still no comms either by router or direct with static IP. I have a feeling I've overlooked something.


#10

try connecting to the BB through the router, and then log into your router to see if the BB is acquiring a DHCP/IP address. If the image is loaded, it should broadcast its client name as "OpenROV". Then log into the OpenROV by entering its ip:8080 (ex. 192.168.1.104:8080)



#11

Thanks, the ROV does not acquire a DHCP/IP address from either my router, or a switch.

How long does it take to load the image? I watched the startup on the bb, the SD card access led (1) only lit up for a second.


#12

It should take about a minute for the BB to boot up; if you still don't see it acquire an address, it might be the image on the SD card. Try one of these methods:

http://elinux.org/RPi_Easy_SD_Card_Setup#Copying_an_image_to_the_SD_card_in_Mac.C2.A0OS.C2.A0X_.28command_line.29


#13

Part success. Used a new crossover cable to router. bb shows as "COM-MID1" in the DHCP connections table. The image is obviously not mounting in the bb.


#14

Solved. Used a new SD card, and copied the image using OSX RPi-SD card builder app

I used the graphical interface first, before trying the command line, as I have no experience with command line at all.

Thanks for the help everyone.