Incorrect voltage from LiFePO4 batteries?


#1

Hi folks,

I have just fired up my 2.6 ROV for the first time, and I only get the outer two lights on the topside adapter and no lights at all on the controller board.

I noticed two things -

1. I have ~9.77 volts from each battery at the DB25.All the directions say it should be 12? Adding up 3 x 3.2V seems like this is correct.

2. If I short the "power switch" pads next to the OC1, the controller lights fire up and look good. Is there supposed to be a component on the board there? I just have two empty pads.

I know there's been a few posts about this which seem to boil down to the DB25 being wired incorrectly, and I will delve into them, but if anyone could confirm about the battery voltage (and share your "I fixed my no-power situation" stories!) I would be much obliged. Thanks.

Andy


#2

The LiFePO4 batteries run at a lower voltage than the trust fire batteries, the trust fire batteries at full charge sit at around 4.2V each (12.6v per tube) and the LiFePO4 are 3.2 (9.6v per tube).


Have you tried hitting the button on the topside adapter and then waiting for it to reconnect? Also the wires are in the correct orientation on the topside adapter I'd assume? I had a problem with not having enough wire stripped from the blue and yellow wires for the connector to "bite" onto.


#3

OK, Thanks - that's good to know. no luck after resetting the homeplugs, but...

I checked out my DB25 and yep, the whole second row of connections was backward. So once I fixed that, i now have power on the arduino (power LED is green, one solid red and one flashing red, one yellow) and the beaglebone (lights at the ethernet connector and blue flashers on the board. However - no ethernet connection at the topside adaptor.

I connected the beaglebone directly to my laptop, and I was able to see the cockpit (no video or response to commands, but hey one thing at a time)

so what's next - test the homeplug adapter on the rover somehow? I don't know how to do that.

Andy


#4

Tried waiting 10 minutes for the homeplugs to connect - no luck. I feel like the homeplug adapter on the ROV is the culprit...


#5

Hi Andrew:

If you have a 2.6 ROV, there are 3 LEDs on the Controller board that show the state of the ROV Homeplug adapter, similar to the 3 LEDs on the topside box. Which if any of those LEDs are on?

If none of those LEDs are on, then the adaptor isn't making good electrical contact. Remove the BeagleBone and make sure that the adaptor is fully seated underneath it. I use some double-sticky tape from the ESCs to stick the adaptor RJ45 connector to the circuit board.

If on the controller board the HP power and ethernet LEDs are on, then try resetting the ROV homeplug adapter the way you did with the topside one.

Hope this helps.


#6

Thanks, Walt. The controller board has:

TPWR-Green

HP - Off

ETH - Orange

PWR - Green

D13 - Red

D49 - Red Flashing

So I reset the homeplug adapter again with no change. Maybe I can somehow connect the two homeplugs together to see if they work.


#7

I tried another thing - switching the two home plug adapters. I figured that if the onboard one was truly busted it might not show the power and ethernet LEDs but I got the same situation - just those two lights on the topside adapter and no homeplug connection.

Is there a way to tell if the onboard adapter is getting any power?


#8

Hi Andrew:

The three LEDs -TPWR, HP, and ETH- are the three LEDs for the homeplug adapter that is placed on the controller board. Is sounds like you have the outer two lit (Power and Ethernet connection), so that matches your topside adapter.

I only have one idea left. When you reset your adapters, did you do a quick press of the button, or did you press it and hold it for a long time? If you look through the adapter manual, there's something in there about doing a reset to factory conditions, which involves pressing the button and holding it for an extended period of time. Doing this has worked for a number of people who had puzzling issues with their homeplug adapters.

-W


#9

Well, after a hiatus to do some woodworking, I got back to the ROV today. I had ordered new homeplug adaptors, thinking that maybe one of them got damaged as I was wrestling it out of the case. But after opening them I can see that they have totally different pins between the boards. They have the same model number but the boards have been updated. Bummer. Can I get the compatible boards from you guys still?

Lights have changed now - there is no ETH light.

TPWR-Green

HP - Off

ETH - Off

PWR - Green

D13 - Red

D49 - Red Flashing

So back to the drawing board - by the way yeah I tried holding down the reset buttons for a long time, even at the same time, but no change at all! I'll keep trying...


#10

Alas! I know this pain. This was a major headache for us, too. Can you send me an email with the your info? david@openrov.com


#11

Thanks! I sent. I can pay for the boards, I mean if they didn't work it's probably because I mangled one (though I didn't think so)


#12

Hi Andrew:

Can you send photos of the homeplug boards you recently bought? We need to find out whether you got old V1.1 homeplug boards, or whether Tenda has changed things yet again. Here's an old blog post about the differences between the V1.1 and V2.0 boards, and how they fit onto the 2.6 controller boards:

http://community.openrov.com/profiles/blogs/new-tenda-homeplug-adapter-compatibility-between-2-5-and-2-6

As for the lights, the ETH light should be lit as it's the Ethernet connection between the BeagleBone and the homeplug adapter. For the homeplug, over the last couple of months, several people have noted that the adapter doesn't work well if it's sitting in the vicinity of a wireless router. Sounds crazy, but moving the ROV away a bit seems to make things work. Just thought I'd mention that in case it applies to your test setup.

-W


#13

Sorry Walt, I missed your message! I will get photos up soon. But it's interesting about being close to a wireless router - one is right upstairs from where I was doing my assembly. So I will check that out too.

Andy


#14

OK, I confirmed that bringing the ROV far from the wireless router didn't fix the issue. So back to the homeplug boards - Unfortunately (and this is weird) the new boards are really - really hard to separate. I was bending the board a fair amount just now trying to wedge them apart. I wonder if they have permanently attached them in the new version!

Since I couldn't get them apart I took a photo of the back of the board with the connector and reset button - you can kind of see the pin arrangement from there.

Photo


#15

Hi Andy:

I'm having some problems with the link you provided. Can you just attach the photo directly to your reply? Thanks.

-W


#16

OK here you go...I can't see any fasteners between the boards - maybe I need to just try harder to wedge them apart a bit at a time.


#17

Hi Andrew:

To my eye this looks like a revision 1.1 homeplug adapter. There should be a revision number on one of the circuit boards, though it may be on the inside surface.

You can cut the boards apart as shown in this blog post. To mount it on the V2.6 controller board, you'll have to move some connectors around, as shown in this blog post. Also, the homeplug LEDs on the controller board won't work since in the V1.1 they are mounted directly on the logic board. If you don't want to mess with all that, you might want to just try to get your hands on a V2.0 adapter.

Hope this helps.

-Walt


#18

I'll give it a shot, though it seems that if this doesn't work, I then have a modified arduino board that will only work with the new ones! thanks for your help.

Edit: Actually, I think I will try and just replace the topside board first. Who knows, it might work. I don't think there's any reason to believe that an old/new combination wouldn't be able to communicate.


#19

OK, I replaced the topside board first (as shown here)since I could do that without as much teardown. No joy, in this case none of the lights worked (I think that’s expected). So then I decided to add M/F jumper wires to the arduino board, so I could try out the new Tenda board there without cutting the pins at J18 and J19. I connected up the new Tenda board (noticing that if I did add the female headers there, the board would physically not fit, something to keep in mind) but no luck, now I didn’t even get power to the beaglebone. I feel like that article doesn’t apply to my (newly acquired) V1.1 Tenda boards.

So! Anybody know where to get Tenda 2.0 adaptors, so I can replace the ones I have? That seems like my best bet. Online sources don’t specify the version, of course since it hardly matters to 99% of their customers :smile:

Thanks everyone for your help in this saga…


#20