IMU Problem no data


#1

Hi guys ,
I just finished assembling my Openrov 2.8, everything works perfectly. I just have a problem with the pressure sensor, does not give me the data:
the welds were done properly, and the epoxy was placed correctly, so do not know what is. When activated, the Depth button, the engine upper sometimes wrong, sometimes goes in fits and starts, and not by any given depth it will compass, it alignment. If off the sensor, it all works. Obviously SW v30.0.3, you have any suggestions?

Thank you


#2

any suggestions ?
It may be defective or can I have something wrong?
TK


#3

Hi Airx_bs,

When you are connected to cockpit, on the right-hand side telemetry stream, on the line that reads BNO_INIT, what does it say? There should be a number after it.

Also while in cockpit, try updating your firmware. Sometimes the Arduino firmware on the controller board and the software on the Beagle Bone Black are not synced up.

Firmware update directions here:


#4

Thanks for the information.
I just checked BNO_INIT_STATUS FAILED, also attach a photo.
I proceed, then with updating your firmware?
I have only one question ; the BBB has installed the 30.0.3 version if delivery directly from step 15, that is, only upgrading the firmware of Arduino? or I, re-update Also the firmware BBB, following the whole procedure?
Obviously I do not know if this is the problem, or may be more.
Thanks for the support


#5

tried to update Arduino firmware successfully, but still no data, I would only understand if the IMU has been damaged during installation and then buy another, or the problem is software.
TK


#6

Hi Airx_bs,

So one other question, to determine if your wiring is incorrect or the IMU is bad. Are you getting depth data? If not, then please check the wiring on your IMU. If so, then the sensor must be faulty, and we can replace it for you.

Best,

Nima Torabi
OpenROV Support


#7

No at the moment, I have no data in depth.
I’ll try to unsolder the power wire and solder it again, I think the only thing I can do.
Thank you


#8

Make sure that the wires are all connected to their associated colored wires on the DB25 wiring harness, and that the wires on the solder joints are making full contact.

Also, if you can see through the epoxy, make sure that the where the wires meet the IMU board there is a ring of solder connecting the wires and the board.

Also- make sure that the wires are all in their correct position on the board. If they are not, then you can attach the wire leads on the IMU to the correct leads on the wiring harness.


#9

Hey @airx_bs, could you take a picture of the wiring & soldering?


#10

It seems that the problem is dependent on 3.3 V of the IMU. I measured with the tester the tention of the positive and negative wires eliminating the IMU and arrive 3.3V. So it depends, at this point, by some welding on the base of the IMU. Not being able to know if the welds on the base are done well, I think we should buy a new one.
TK


#11

Did you use clear or opaque epoxy to pot the IMU? If it is clear, then try to see if there is a ring of solder around the wire leads on the IMU.


#12

I used clear epoxy. Unfortunately I can not understand, the welding spots seem to be made well. But if the problem is not the software, I think is the only thing possible.



#13

New IMU, problem solved. Yesterday the first tests with IMU to -40 everything worked.
I set up a WiFi connection to connect Homeplug -Powerbank -Nano ruter, I think is a problem, often the video was in spurts, I think the flow of data is too large for this cluster connection, or maybe the IMU creates this problem. When he was not in the IMU and I had no WiFi connection, the video was fluid.