IMU Added - Dashboard/Camera dead [solved]


#1

Hi all,

my first post here. I am Timon, working on #945. It is supposed to come in educational/scientific use. Tomorrow (in 10 hours) I am flying to Svalbard (Arctic region) to get in touch with the scientific community there and it would be awesome to show the ROV off. So I have been working long nights the past days to get it finished, pressure test in the local lake went, down to between 30 - 40 metres, good.

The hardware build went quite smooth. Everything worked, I was almost about to drop it once more fully functional in the lake before I decided the working IMU would be cool.

Heres the problem:

I did the changes in the AConfig.h and uploaded the Arduino firmware again, Upload process hung up, the cockpit was reachable just on the 3. reboot (I waited every time a while before trying to connect...) and then the Dashboard (Data on the right side) was not visible, nothing controllable.

So I uploaded the Arduino firmware once more, this time the upload went all the way trough. I can control everything and see the Data on the right side. There is no IMU data besides a tilt of -0,70 that isn't true (its laying flat on the desk). But the camera stream is just black.


The CPU usage, which was before at between 30 and 50% is now around 20%.

I uploaded the firmware another time. I checked the camera USB plug.

EDIT: I also tried to connect to the ROV with the VLC Network Stream viewing function, VLC responds it couldn't open the stream.

What else can I do? Any Ideas?

Never change a running system :(


#2

Hi Timon:

If the ROV boots, and you see cockpit and can control the motors, but you don't get any video, try zeroing the depth gauge. Sounds crazy, but there's a crazy bug in the current software that causes this. I believe it has been fixed in GitHub, but it hasn't made it to the released code yet.

As for calibrating the pitch/roll/yaw (compass heading), that's sort of a work in progress right now. For my own ROVs, I've just hand-edited the Arduino code for the specific ROV (I believe the file is MPU9150.cpp or something like that).

Hope this helps. Good luck on your trip. Let us know how it goes.

-W


#3

After pushing the "Zero Depth" button I could see myself on the screen laughing hard about the quick fix, thanks a lot! :D

Yeah, I figured that the IMU is work in progress, just wanted to see how far it would work at all. I am happy when the ROV performs its basic operation so far. I will tinker with it more when I am back from travelling.

My local lake (500m from my house) is roughly 50 metres deep and meromictic, so I hope I will be able to post some interesting stuff soon.


#4

Hi Timon:

I'm glad this worked. Definitely send us some video from the lake. Sounds pretty cool.

The depth sensor has an embedded temperature sensor which reports the water temperature. It will be interesting if you can see a distinct thermocline in the lake, and whether there is a distinct change in buoyancy as you go through the different layers.

-W