I can't connect to the ROV


#1

Hello!

Till yesterday my ROV was working and the only thing I had to do was calibrating the ESCs, but I made a mistake and I had to redo the programming and the calibration of the ESCs. When I finally managed to reprogram the ESCs and I was going to redo the calibration I discovered that now my software doesn't open. I can connect to the ROV. (google chrome says that there is a conection error). In then interface board the light of ethernet connection is on and the laser and some lights on the arduino board are also on so I don't know what can have happened since yesterday.

Regards!


#2

Another thing I forget to say is that now when I try to program the ESC they dont beep :S


#3

I ve been testing the connections and they seem to be all right. I don't know if its a problem of the arduino board or of the beaglebone. The laser and light have voltage but the motors dont received. I'm worried becaused the ESCs doesn't seem to work at all.


#4

Hi Javier

Test things one at a time so you can verify what works and what does not work.

1. remove the BBB from the control board and remove the USB Camera.

2. Power up the BBB with a USB cable or adapter,

3. Connect a Lan cable directly to your laptop and set the proper IP Address on the Laptop to

192.168.254.1 Subnet 255.255.255.0

3.test to see if you can get the cockpit to connect or use putty utility on your laptop to see if you can connect to the console.

let us know if this part works then we can move on to the control card.


#5

Ok, I'll do it when I'm back at home and tell you.

Thank you!


#6

The Laptop should be set to 192.168.254.2

192.168.254.1 is the OpenROV address sorry for the mistake


#7

Sorry I coudn't do it yesterday. I've arrived home now from my journey and it is too late here in Spain. I'll do it early in the morning and tell you my results. I've just connected the BBB directly to the power and all the blue lights have turned on, which is something that didn't happened since I started having this problem, so if tomorrow I can connect the BBB through the ethernet to the computer the problem may be in the communication or in the medialink powerline network adapters, isn't it? But I don't understand why the lasers still turn on?

Thank you for your help!

P.D: In the first photo, you can see that the only thing that turns on on the electronics when it's connected as it should is a single green lights, the lasers and two lights in the box but not as it used to somedays ago.

377-connected_to_the_computer_11.jpg (2.54 MB)

#8

Hello!

As you predict it, if I connect the BBB directly to the power and to the computer by ethernet, the cockpit works! so the problem seem to be that the BBB is not receiving power. I've test the batteries and the are correct, and the laser still works. So where do you thing the problem is?

Thank you!


#9

P.S: I m trying to connect the ROV as it should be, and I'll power the BBB directly to see what is failing.


#10

Hi Javier:

In the first photo you posted ("connected to the computer"), the homeplug adapter on the ROV is not getting any power. If it were, there would be a second green LED lit, the one marked "TPWR". That is the reason you are not getting any communication over the tether.

Most likely what has happened is that the Homeplug adapter (under the BeagleBone) has come off of its mounting pins. Pull off your BeagleBone and make sure that the adapter is mounted correctly. I would use some double-sided tape between the controller board and the RJ-45 jack of the homeplug adapter to hold it in place.

Let us know if that helps things.

-W


#11

Hello!

I ve just made sure that the homeplug adapter bellow the beaglebone is mounted correctly but it still doesn't work, so I guess is it not the pins. I'll try again and I'll upload some photos.

The other homeplug adapter only has the two lights of the extremes on ("power" and "ethernet connect") but the middle one ("Homeplug connect") only turns on orange when I ve just connected it, but it turns off fastly.

I've also tried to connect the beaglebone to the computer going through the homeplug adapters and the tether, powering the BBB independently and it hasn't worked, so the problem must be on the adapters, but no idea where.

Thank you!


#12

Hello!

I've also tried to connect the beaglebone to the computer going through the homeplug adapters and the tether, powering the BBB independently and it hasn't worked, so the problem must be on the adapters, but no idea where.

I've also tested the voltage in the DB-25 and both batteries give 12V so that is right!

Thank you!


#13

P.S: Since when I connect it all at should, neither the BBB neither the homeplug adapter got power, but the arduino is receiving 12V. So I've thought that it could be also a problem in the arduino board, that is't feeding the BBB and the homeplug adapter. What do you think?


#14

I am not sure if it is an easy thing to do to switch the homeplug adapters as I do not have the same topside setup, but if you can then you can see if the homeplug adapter that was mounted on the controller powers up ok on the topside pcb. As Walt has mentioned if the Homeplug mounted on the control board does not get powered up then nothing will work correctly. The HomePlug requires +3.3V to power on. There are jumpers J12 & J17 that will bypass the HomePlug power on feature to power up the Control board for bench testing, If the Homeplug still does not power up, you can plug the Lan cable from the laptop directly to the BBB then you should be able to have everything working except the Homeplugs and tether if the control board is working ok.


#15

Yes, if I connect the Lan cable directly everything works, as long as I also power the BBB independently of the batteries. I mean, neither the homeplug adapters neither the BBB are receiving power. I'm not sure but I suposse they are meant to be supplied by the arduino board pins.

I ll try now to switch both homeplug adapters as you've said and I'll tell you what have happend.

Thank you for your help! I appreciate it a lot!

Regards!


#16

Hi Javier

Try placing jumpers in J12 & J17 this will power up the control board and also power up the BBB and bypass the Homeplug Adapter power on feature.


#17

Hi David

I've done what you told me and I've switched the homeplug adapters, and now the BBB has power and an the lights turn on on the arduino board, however, the homeplug adapter next to the computer (that used to be bellow the BBB) doesn't have any light on and seems to don't be working at all, so I think that this could be the problem, am I right?

Thank you very much!


#18

By the way I have another problem. It seems that the media link power line adapter is only sold there in the States and they don't ship to Spain. So if this is the problem I don't know how could I get another one.

Regards!


#19

Glad to hear that you have made some progress,sure sounds like the Homeplug adapter may be the issue. The Control board powers up by applying +5V on the tether wires which I assume is the case for you, or if you bypassed the homeplug power up feature and installed jumpers at J12 & J17 that will power it up. As for the Homeplug contact David Lang and ask him if he can send you one, you will have to let him know what version you have.

Other folks have used the European versions of the Homeplug but that will require some changes to how it's wired in if you wanted to get up and running a bit faster. But if you can wait for the US version it may make your life a bit easier.


#20

I've exchange the broken MediaLink powerline adaptor for the new one and now it seems that all get power. But in the OpenRov Topside adapter the middle line (homeplug adaptors) continues off. So I thing it might be broken as well so I've ordered a new one.

Regards!