How to build a WiFi enabled Tether Router setup problem


#1

Hi All,

I have been using Nils Jakobi’s “How to build a WiFi enabled Tether Management System” on the OpenROV Community Hacks as a guide to programming the newer TP-LINK TL-WR802N Wireless N300 Travel Router.

One of the first problems is that the router cannot be communicated with over the wired LAN link initially. It will not respond to IP 192.168.0.254 like the TP-Link N150 Wireless Travel Router that he used. I have been able to talk to it over its WiFi link and have changed the Working (Operating) Mode to “AP” per his instructions. I have then verified that I can talk to the router over the wired LAN Link at IP 192.168.0.254. However when I set the wired LAN link to a Static IP of 192.168.254.2, per his instructions, to be able to communicate with the OpenROV Cockpit, and reboot, I can no longer communicate with the router over the wired LAN link using IP 192.168.254.2 from my laptop.

Perhaps this 300 Mbps version of the original 150Mbs router has substantially different operating firmware and may not work in this application?

Apparently Nils Jakobi is no longer a member of the OpenROV Forum as I cannot send him a message or I would ask him directly.

Any suggestions?

Regards,

TCIII AVD


#2

Hi All,

After searching the Amazon user reviews for the TP-LINK TL-WR802N Wireless N300 Travel Router it turns out, unlike the TP-Link N150 Wireless Travel Router, the TP-LINK TL-WR802N Wireless N300 Travel Router must be setup over its wireless link and not the wired LAN link as was done in Nils Jakobi’s project.

So I am going to have to figure out if the TP-LINK TL-WR802N Wireless N300 Travel Router can be setup over the wireless link the same way the TP-Link N150 Wireless Travel Router was setup over its wired LAN link.

Regards,
TCIII AVD


#3

Hi All,

Good news! I was able to get the TP-LINK TL-WR802N Wireless N300 Travel Router communicating with the OROV 2.8 Controller Board.

What I did is follow Nils Jakobi’s instructions for setting up the Wireless Router, but did it over the Router’s wireless link instead of using the Ethernet LAN cable. Also, instead of selecting each setting individually like Nils did, I used the Quick Setup in the Wireless Router’s menu and set each parameter per his instructions as it came up in the Quick Setup dialogue. Works great on my HP 15.6 in laptop with minimal lag.

Now all I have to do is figure out how to get Cockpit to run correctly on my Samsung Tab 2 10.1 Android Tablet. All I get is about 1/2 of the Cockpit display and no video.:confounded:

Regards,
TCIII AVD


#4

Hi TCIII,

I am working with the latest openrov software image 31.0.0. with my v2.8 ROV and a 300Mbps Wireless N Nano Router (Model No. TL-WR802N from TP-LINK).
It was not working after I followed through the Nils Jakobi’s guide. And then I saw your post. However, even after I setup the router over the wireless, I still could not launch the cockpit or wetty.

I have done some troubleshooting.

  1. when directly connect the Ethernet cable from topside board to my Laptop (not using any router), I can launch cockpit and wetty. The assigned IP to my laptop is 192.168.254.14

  2. however, when using the Nano router, I am able to ping 192.168.254.1 (the ROV’s IP) and 192.168.254.2 (the router’s IP) and the assigned IP to my laptop is 192.168.254.100 (I am able to ping this address as well).
    But I cannot launch cockpit or wetty.

  3. I have also re-burn the image and the issue persists. (I guess it is not an image issue, since it works fine without the router)

  4. I have noticed a few settings that were not mentioned in Nil’s guide but only shown in the photos.
    In his guide, step 4. under wireless security, the “group key update period is 86400 seconds” and under the DHCP settings, the “address lease time is 120 mins”. I have tried both default values and the values shown in the picture, both cases, I cannot launch the cockpit or wetty.

what could be the problem here?

Thanks
Sun


#5

I have been thinking about the IP address stuff.

when there is no router in the system, the software image 31.0.0 will try to assign a dynamic IP address to my laptop (e.g., 192.168.254.14) when there is an Ethernet cable between the topside adapter and the laptop.

Once we add in the router, the router assigns a “static” IP address to ROV which happens to be the same static IP of the ROV, i.e. 192.168.254.1. at the same time, the router assigns a dynamic IP address to my laptop with a lease time of 120 mins, e.g., 192.168.254.100.

what happens to the software now, is it still trying to assign an IP address to my laptop or it is intelligent enough to talk to the router and the chrome browser?

when we launch cockpit from our browser, we send the request to router and the request is being routed to the ROV, the ROV then send back the response to router through wire, after which the response is received by browser through wireless.

If I cannot launch the cockpit, it is either the request is not being sent out or the response is not being received.

but what cause the problem?


#6

hi, I have managed to connect to cockpit using router after I edit the hosts file as described by IchthyoEcologist at