How do i reverse the motors and get the servo to work properly?


#1

Hi!

First of all i want to thank Eric and the team for a great product!

I have managed to get all the parts together but having some problems with the motors and the servo. With the motors i can´t go reverse. Right, left and forward works as a charm. Diving (CTRL) also works but SHIFT does not. It´s the same problem when i run the diagnostics through the cape. Reverse is not working. As for the servo it´s more dead than alive. when i start up the cape it make some noise. Sometimes when i press a button (Q, A or Z) it moves some millimeters, this can go on for a couple of seconds then i stops and will not respond anymore. It feels like the servo live a life of its own.

Is there anyway to run a diagnose/test on the servo?

Any ideas on how to get the motors to go reverse? I have programmed the ESC:s by following the steps from the wiki.

The lights and the camera works well.


#2

1. Use Google Chrome

2. Is th jumper removed on the Cape while the ESC's are connected and powered up?

3. You mentiond that you programmed the ESC's but did you also calibarte the ESC's.using the cockpit Diagnostics. http://wiki.openrov.com/index.php/Programming_the_ESC

4. If you disconnect all the ESC's then insert the jumper on the cape, this should power the Servo for the Camera for testing. Make sure to remove the jumper before connecting the ESC's back up after testing.


#3

Hi David,

Thank you for answering.

I use Chrome and the jumper are removed while the ESC´s are all connected and powered up.

I once again updated the BB with the latest software and found out that performance where slightly increasing. The ECS´s are both programmed and calibrated through diagnostics in the cockpit. Yesterday i noticed something strange though. When I was reversing the motors with the new diagnostics function in the cockpit the keys that did not work came to life. For example; before reversing (by selecting the check-box in diagnostics) the CTRL key controlling the vertical thruster worked and when reversing in diagnostics the SHIFT key was the one working spinning the motor the opposite direction. When in "reverse mode" the CTRL key was no longer working until switching back to "no-reverse".

Also, when i test the motors in diagnostics and goes from 0 to max reverse the motors will not respond. However, when i go back to 0 and the again pull the slider to reverse again the motor will start spinning in reverse...

Could this be a consequence of me calibrating the ESC´s in the wrong way?

Maybe i should try updating the Cape again? Could this be the problem?


#4

Hi Andreas

Looks like you are making some progress which is great.

1. You mentioned that you reprogrammed the BB but did you also update the Arduino code?

2. Because you are able to get the motors in reverse through the diagnostics tells me that you probably have them programmed correctly, but maybe there is a code issue.

3. It sounds like some recent changes may have been made to the BB code which I have not tested yet. I don't have my ROV fully assembled at the moment to test things but Maybe Brian or one of the others can chime in here with an answer.


#5

I´m also trying to find a new solution for the batteries to fit in the cape.

Is there enough whit three parallel LiPo 11.1V 1.300mAh for the ROV? In short; Is 3900mAh enough? If so, does anyone know the approximate running time?


#6

I seem to remember around 1hour runtime mentioned, but it really depends on how much you fly around, and on what speed.

Btw: if you move the batteries to inside the electronics tube you shift the weight balance in the rov.

the batteries are in the tubes on the bottom to have the heavies part under the buoyant part(electronics tube). the position of the battery tubes length-wise is to counter balance the weight off the motors.


#7

Hi all!

I managed to solve the problem with the motors.

The problem was that i couldn't reverse the motors correctly. Somehow the calibration of the ECS´s have been lost. Maybe this was a result of me not calibrating all off the ECS´s at the same time? Just a speculation...

However, when i once again calibrated all three ECS´s and updated the Arduino the motors worked perfectly!

@Thomas; Due to the change of the buoyant i will go with the original solution for the batteries. Thank you for the information!