HomePlug connection stopped working (again)

solved
electronics

#1

I have upgraded to the 30.0.0 image a few days ago (OpenROV 2.6), the first 2 days it worked well (a couple of times it didn’t connect properly but poweroff/poweron has always worked)

However, since yesterday I am having a problem very similar to what I had before here.

I can no longer connect to with the Home Adapters.

  • On the topside, Power and Ethernet are on, but not HP.
  • On the ROV side, TPWR and ETH are on, but no HP
  • I can connect to the dashboard if I connect straight to BBB with
    an ethernet cable.
  • I have 5V(4.7V exactly) over the tether on both sides.
  • I tried switching the Homeplug boards (topside in the ROV and vice
    versa) I get exactly the same problem.
  • The Tenda software (PLC?) that comes with the homeplug can only
    detect the one connected on the topside. (Even when switched)
  • I tried to re-sync and do factory reset but I still have the same
    problem.
  • Ohm-meter test on the cable looks good.

What could it be? What other debug steps remains to be done?

Do you think it’s just a simple pairing issue? Why did it stop working suddenly?

Thank you in advance.


#2

After long hours of debugging, I managed to get it to work again, here is what I did for the sake of documentation:

  • I discovered that the pair/reset sequence is not the same on both my adapters (holding for 1-3 seconds would activate pairing mode on one adapter but not the other) I believe that this caused by the fact that I didn’t have identical adapters (check link in 1st post)

  • I did a factory reset on both adapters (watch the flashing LEDs to be sure you’re in the right mode), followed by pairing (sequence was different on each adapter, depending on the exact model, eventhough both were tenda 200 adapters).


#3

Hello,

thank you for sharing your results. At the moment I am in exactly the same situation you were in. Everything is working fine, but I cannot get the Home plugs to pair. I had finished building my 2.6, got everything working and was just testing another notebook. Everything worked well, but after a few minutes the top side adaptor lost the connection. I did lots of trouble shooting and read a lot on the forum until I found your post.
The pairing sequence on both adaptors is randomly activated with a button pressing time between 3 and 12 seconds. When I am lucky enough to get both of them in pairing mode, they do not find each other. The tether shows satisfactorily results when measured with an multi meter. I got 4,7 V on the data line and 3,3 V for the adaptor. Right now I am waiting for new home plugs to arrive which I ordered.
I suspect I messed up the programming on one or both plugs because I had the notebook on the 230V plug. In my flat there are other power line adaptors in use. On the forum other users reported problems with having the ROV notebook plugged into an AC power circuit with other power line hardware in operation.

Olaf


#4

Having others with homeplug adapters on your circuit can cause trouble when trying to connect, but it won’t damage them or anything. Another issue is if you are too close to a strong wifi router. I discovered that many of my connection troubles went away when I moved my work space away from the router. :smiley:
I also have far far fewer connection issues when I’m out on the water.


#5

I have switched off the wifi on my router and I only get very low signal strength from neighbouring wifi spots. But still the homeplug adapters wont pair. Maybe I should try in the basement, it is so heavily shielded from the steel in the concrete that there is no wifi visible there at all…
I was wondering how long it usually takes from plugging in the usb cable into the topside adapter until the homeplugs have connected. Does the ROV have to have finished booting completely or can the connection between the homeplugs be ready while the ROV is still booting? I did not pay attention to this while it worked. I waited a few minutes but maybe I was not patient enough.

Thank you!
Olaf


#6

I didn’t notice any interference from wifi, even though my AP is next to my workstation.

When I paired the homeplugs the BBB was not even connected, it was easier to access the reset button this way. It doesn’t take very long to pair, I think less than a minute.

Try factory reset then repair, that worked for me.


#7

the pairing is usually very fast and does not need the bbb to be on at all. Sometimes though, if there is an issue, it can take a while, then suddenly it works fine.
Try the suggestion above of factory reset etc. If that does not work, try your basement, using the battery power of your laptop, so that nothing is connected to your home power, the way it would be when you are in the field. If that works, try plugging your laptop into the wall to see if anything changes.

I have had the problem you are having. It sucks. I hope you can get to the bottom of it.


#8

Thank you for the input! I will try the suggestions this afternoon after work and keep you updated how it works out.


#9

The problem is solved.
Turns out it was indeed my power LAN adapters which I use to connect my desk computer to the router which is in the hallway of my flat. Even when only one of them is connected to the power circuit it causes enough interference trough radiation from the power cables in the wall to prevent the home plugs of the ROV to pair. (My notebook is not connected to the power circuit, I am using the battery) As soon as both of my power LAN adapters are disconnected from the power circuit the home plugs of the ROV pair in a few seconds and everything works perfectly.
Even in the basement one plugged in power LAN adapter in my flat on the first floor prevents the home plugs from pairing because the signal travels in the cables down to the basement.

Thank you very much for your help and input!

If I am lucky, I can have the maiden of my ROV on the weekend.


#10

Ya, the home plugs are funny in that if they are all on the same connection they work great! But if they are in proximity to each other but NOT on the same circuit, they do some weird cross talking. :D.


#11