Homeplug connect not turned on/ everything except camera not working

sos

#1

Hello, I have problems connecting to my openrov 2.8.
Problem 1
When I try connecting it through the topside communications box, I only get 2 LED’s to light up (Power and Eternet connect). The middle one never comes on. When I try loaging http://192.168.254.1:8080/ in my chrome browser, It says that the connection timed out.
Problem 2
When I try circumventing the first problem by directly connecting the usb and ethernet cables from my computer to the BeagleBone, I am able to connect to the ROV cockpit through chrome and to see the video images captured with the camera. However, I can’t get the lasers, motors, lights or any other accessories to work. Also, I get a 0V reading for my battery voltage.

What could be the issue(s)? Please help!
Thank you :slightly_smiling:


#2

Double check the connection from the beaglebone to the other board via the single pair cable that connects to the ethernet ports on each board. I had trouble initially with my 2.7 where this connection was barely connecting due to the cramped location of the cable, try to reseat that and without putting everything back in the tube see if it powers on as expected.


#3

It sounds like the BeagleBone and your controller board are not properly communicating.

The first thing to check would be that the boards are pressed together all the way and that the pins are aligned correctly.


#4

Hi mac-p-a:

I would not recommend running a USB cable from your laptop to the Beaglebone. If you do that it will attempt to power the BeagleBone through the USB +5V supply, and this will be in contention with the +5V supply on the Controller Board. I don’t know that it would do damage, but I would avoid it just to be safe.

When you connect to the BeagleBone with an Ethernet cable, you still need to turn the ROV on. OpenROV is powered by placing a small voltage on the tether, which the controller board senses and uses to turn on its power supplies. So, to turn on the controller board, keep the USB cable running to the topside box, and the topside box connected to the ROV via the tether. This should power on the controller board, which will in turn power on the BeagleBone.

If you see power lights on the controller board, and you still don’t see the controller board functioning (lasers, motors, lights, etc), then I would check the BeagleBone alignment as referred to by BrianG above.

-W


#5

Hi guys,
First, I wish to thank you for your quick replies.
I tried everything that Walt_Holm, Brian_Grau and chanchaval suggested, with no success. I am now certain that all my wires/boards are correctly installed, as I checked all the assembly manuals and read through most of the forum posts on that subject. My problem still remains: when I try connecting my ROV through the topside box, the middle LED does not light up. Therefore, it is impossible for me to connect to the ROV cockpit.
I’m starting to think that my controller board is defective. No LED ever lights up on it, and even trying to install the firmware dosen’t work.

Is it possible that the controller board is defective? It seems to me like I tried everything.


#6

Are you using the ROV near a wifi router??? check out this thread [SOLVED] Cannot connect to my openrov


#7

Hi Mac-p-a:

Forget about the lights on the topside or downloading firmware for now. Nothing’s going to work until you get the controller board turned on.

It is possible that it is defective, though this is not likely- every controller board gets tested at the factory, and the power switch circuitry has proven to be quite reliable. So here are some things to try:

  • Are your batteries fully charged? When you examine the battery contacts in the battery tubes, are they free of contamination like epoxy, glue, whatever?

  • Make sure that you’re not putting the batteries in backwards, and that the battery tube wiring is not backwards from what’s in the instructions.

  • If all that looks OK, set up your ROV with the clear main tube off but the controller board installed on the endcap. Use a short piece of wire to jumper across the two contacts of Controller Board J12 (this is marked as Power Switch, it’s just under the barrel connector of the BeagleBone). Does this turn the controller board on? If so, then there’s probably an issue with your tether wiring.

Give that all a try and let us know how it goes.

-W


#8

Hi Walt,
Once again, thank you for your help. I will only be able to test what you suggested tomorrow, as the ROV is at my part-time job. However, I know I double (and triple) checked the batteries to make sure they were fully charged and properly installed.
I haven’t tried wiring the two contacts of controller board J12. I shall try it tomorrow. Say the controller board doesn’t turn on, what would be the next step?
If I understand correctly, if the controller board turns on after this test, re-doing the tether wiring would assure that the 5V coming from the computer succesfully reaches the controller board? The controller board needs the 5v current coming from the tether to turn on. Does that mean that It can only draw current from the batteries once it is turned on?

I’m a noob with electronics lol.
I appreciate your help
Pierre


#9

Hi Pierre:

If you short the contacts at J12 and the controller board doesn’t turn on, then the next step would be to figure out if battery voltage is getting to the controller board. You would need to get a voltmeter, and measure the voltage at the DB-25 connector J5 where the power comes in- you should find about 9.6 volts when you measure between pins 5 and 4, and when you measure between pins 6 and 7. You can grab the schematic of the controller board on our electronics github site here. Connector J5 is on sheet 2 of the schematic.

As to your last comment, yes, the 5V on the tether throws a switch on the controller board, which then sends battery power to the processors on the controller board. If the controller board is not correctly hooked to the tether, then it will never turn on (unless you jumper J12 as described above).

Hope this helps.

-Walt


#10

When I was building my 2.8, I also have troubles in connecting it. As you guys have mentioned, wifi router
will interfere.
https://openrov.yonyx.com/y/conversation/?id=7c5b2d70-eac3-11e4-a42b-bc764e1028dd&h=1&st=0 This link help me a lot during my testing. It teaches you to check step by step. I hope it will help.