Hobbyking 10A Car ESC problem


#1

Hi,

i’m using this motor (not the ESC that’s included since it has no reverse) :

this ESC :

and a 2S LIPO battery.

Since Hobbyking couldn’t tell me the PWM values to send to the ESC in order to make it stop/forward/reverse i thought i’d test it with the Arduino Uno using a potentiometer.

The problem is that the motor just beeps continuously, which i’ve read is a sign that there’s no signal on the data wire.

But i know that there is a signal on the data wire since the Uno is sending the pot value (mapped to the correct range).

I’m using this tutorial as a basis :

http://www.techmonkeybusiness.com/esc-calibration-using-an-arduino.html

but instead of using LEDs i just use output on the serial monitor to tell me when to connect the ESC.

The motor just bleeps quickly and constantly, does anyone have any ideas what may be going on?

I’ve tested 3 brand new ESCs and all behave the same so it’s obviously something i’m doing wrong!

Cheers, Gary.


#2

Hi Gary:

One thing to realize with car (reversible) ESCs is that they won’t arm until they receive a PWM signal that is within their dead zone, typically something like pulsewidths of 1500+/-50 microseconds. To get the ESC to arm, you’re going to have to fuss around with the setting of the pot, somewhere in the middle of its range.

As for whether there’s something more fundamentally wrong, it’s hard to tell from your description. Using an Arduino to generate a pulsetrain is admirable, but without an oscilloscope it’s hard to say for sure whether the thing is working or not. You could try hooking up a voltmeter to the Arduino output, and seeing whether the average voltage seems sensible- if I’m doing my math right, a 1500 usec pulse at 60 Hz is about a 1% duty cycle, so the output pin should be about 1% of 5 Volts or about 50 mV.

Or, if you’re going to be doing a lot of this kind of work, I’d just break down and buy a servo tester. They’re not particularly expensive, and they come in very handy at times. Here’s a typical one on Amazon:

Hope that helps. Let us know how things progress.

-W


#3

Thanks Walt, that’s very helpful.

I contacted the writer of the article and he’s shed some light on the subject too, it was my lack of understanding rather than an actual fault :confused:

I was changing the number of degrees i sent to the throttle (0-180) rather than the min/max PWM values, so i’ll try playing with the PWM values later.

Thanks again for your help and i will keep you posted, it’s a very exciting project and i’m learning a lot.

Best, Gary.


#4

Problem partially solved.

I can initialise the ESC now but only if :

a) The Uno is powered from the BEC and not plugged into USB or mains adapter.

or

b) The Uno can have USB and the adapter plugged in but only 1 of the BEC’s power leads are plugged in.

I don’t know enough at the moment to understand why the above two cases apply but i’ve moved forward a little!

I can’t get it to go into reverse yet (though i’ve programmed it with a programming card for the correct mode).


#5

All works now :slight_smile: