Help need to understand why I smoked a Motor


#1

I had just finished programming the ESC.
Connected the Motor to one 11.1v LiPo Battery

Connected The Electronics to another 11.1 LiPo Battery.

Could not move camera or Vertical Motor

I did not have the grounds on the 2 batteries tied together nor the + side.

I pluged in the Jumper on the Cape to get the 5V then I could move Camera.

Started using the up & down arrows and had the motor moving both directions if I recall

Then full stop and a big puff of smoke from the motor.

I am not sure what caused it as I was hitting the up and down arrows a few times.

Any help would be appricated.


#2

when a coil(a BL motor consists of 3 coils) looses its power, the magnetic field wants to stay on, and a high voltage spike is generated, this is normaly consumed by some capacitors in the esc, but if you are heavily running full speed(i think the keyboard function is full throttle, and reverse) and switching rapidly over to reverse, you have most likely made a high enough voltage so two of the coils has short-circuited.

or it could just be a manufacturing defect.

Note: NEVER connect the jumper when the 18a hobbyking esc are connected. they send out 6V that can damage the cape and BB. the 6v from the esc shall provide power to the camera tilt servo.

ground is shared via the cape if you have one battery on the cape, and one the esc.


#3

Ok I got a bit braver and tried programming a 2nd esc and used a new motor. This time I just used 1 LiPo Battery 11.1V to power everything. I made sure the jumper was pulled before applying power. I do not get any movement of the Camera or Motor. There are no lights on the ESC at this point. So I disconnected the ESC & Motor from the Cape then reinserted the Jumper, I am now able to make the Camera go up/Center/Down using the Q,A,Z keys. The Cape that I have is I think the Newer one as it was shipped to me in January. So the question I have is related to the Jumper and Cape Version and if this has anything to do with the Servo not working when the jumper is removed and the ESC & Motor are connected. I tried the ESC Control connector plugged into each port P/S/H with the same result. I will start looking at the schematics to see if I can figure this out but if anyone can shed some light on this issue it would be most welcome. I do have a spare Cape but did not want to use it until I get a handle on this issue.


#4

try this:

-disconnect all the esc's,

-plug in the jumper

-connect the servo to the first ESC output.

- go into diagnostics on the console and move the sliders for the relevant esc output.

see if the servo reacts to the movement...

The esc will not "arm" unless the signal is equal to the mid-point signal that the esc is calibrated with.

i think you should try to recalibrate the endpoints.

John S, here on the forum have experienced that its easier to calibrate the esc if the voltage is lower than 8-9volts.

I actually used the servo(cam-tilt) output to calibrate the esc end-points, this worked perfect for me. i used a lab-supply set at 12volts to supply the esc and cape.


#5

Thanks Thomas

I am a NewBee to ESC's and Servos, After some brave decision making I decided to turn the ESC switch to ON :) then I now had power from the BEC to the Servos. I thought the Switch was only used for programming the ESC's. I now got the Camera Servo working as well as one Motor. I will now need to do some further testing on the remaining esc's and Motors. As for the One Motor I smoked I am still not sure why that happened so it could very well have been a bad Motor or ESC. So I will now need to test the ESC that burned out the motor I know that I did not have the esc switch turned on when that happened so I could very well have had a bad ESC as well. I know when I was programming the Suspect esc again with a good motor attached that the ESC became hot and I do not recall that happening to another ESC that I programmed. I am not sure if this is in the documentation or if it is I may have missed it, but may be helpful to others who may not be familiar with ESC's.


#6

Thanks Again for your tip on troubleshooting I have now made lots of progress.

I now have found out that the the 90 setting in the BB is putting my Motors in a CCW direction when things power up. I have found that the neutral point is 95-96 so the motors CW turn on at 99 and off at 97 then CCW on at 92 off at 94. I have tested all 4 of my ESC's and have one that is not working in CCW motion. This is the ESC that burned up my Motor so I suspect it may have been the cause of the Motor Failure. I will dig into how I can change the neutral setting from 90 to 95 or 96 or re calibrate something, but if you can give me help as to what I need to do that would be a help.


#7

Oh Ya keep fingers away from a spinning fan, 6 Hours last night sitting in an emergency room was not fun. I have now learned to test without the fan blades attached :)

1520-P3230041.JPG (610 KB) 1521-P3230038.JPG (671 KB)

#8

check the leaflet that came with the esc(you will also find it in the files section on the productpage on hobbyking). the first part describe how to set the middle, full and reverse point.

this is performed with either connecting each esc to the servo output, and use the keys to mimic midle, forward and reverse(q-full forward. a-neutral, z-reverse)

or you can use the sliders to set the points to 0-90-180 (90 being the midle, 180 full forward, and 0 full reverse.)


#9

Perfect it now works like a charm thank you for your Help Thomas. I had another look at the assembly instructions and the part for calibrating the throttle of the ESC and it does not mention how to do this so I am sure others may run into this same issue.


#10

ouch! I'm glad you're okay!