HD Camera Not Operational

camera
software
electronics

#1

I’ve managed to make everything work except for the HD camera. It seems that it may be that my Windows 10 is the issue since my teammate can get imagery on his Mac. We updated the image via SD card to get his operational.

When I start OPENROV Cockpit the image is not seen.

Thanks for any help.


#2

Check out this thread.


#3

One easy fix that I’d like to mention is to make sure that you are pasting this URL into your browser: 192.168.254.1/cockpit. If you try to use the 192.168.254.1:8080 address you will not get video feed with the HD camera.

Could you tell me more information about the other details related to your HD install? Are you saying that you and your teammate are connecting to the same ROV and everything works fine for him but not for you? More details about that will help me get to the bottom of your problem.

We wrote a troubleshooting guide that helps debug connectivity problems, go here to try it and see if it helps solve your problem:

https://openrov.yonyx.com/conversation/7c5b2d70-eac3-11e4-a42b-bc764e1028dd/

Let me know how that goes and we’ll take it from there.

Lorah
support@openrov.com


#4

Sorry for the late reply.

@lorah I have made sure to be using the correct URL and I followed the connectivity troubleshooter but it didn’t seem to help as I ran into a dead end and it told me to contact support. Instead, I am now able to connect to the 8080 address (which leads me to believe it linked me to the non-HD software?)

@Jim_Scholz I tried following those steps but I think I messed them up upon second look so I will give them another shot.

Thank you both for the help I will update Sunday when I have a chance to get back in the shop.


#5

@lorah the troubleshooter instructed me to flash a new image on the SD card, but I am afraid that this is a image for the regular camera since, as I mentioned, the :8080 address works, but the /cockpit one does not. I have dug through the forum and the github repositories but was not able to find a download of the HD camera image that the SD card shipped with. Could you please advise as to how to get the HD camera image back on the SD card so I can try reflashing that instead of the standard camera image so we can go from there? Thanks!


#6

Here is what I did that worked for me, but I am using a generic HD camera. I downloaded both the 30.0.3 and the 31.0.0 images and burned them to flash. Then I flashed the 30.0.3 to the Beaglebone and updated the OROV board. Once the download was successful I installed the 31.0,0 board in the beaglebone and LEFT IT THERE. I was able to go back to the 30.0.3 cockpit (which I like better) and still get my video but I had to update a couple of times for it to take.


#7

@Jim_Scholz thank you for the reply.

By generic HD camera do you mean the one that came with the ROV or the HD upgrade? Additionally, do you know where I could find the 31.0.0 image? The product page seems to only have up to the 30.0.3 image available: https://www.openrov.com/products/openrov28/


#8

By generic I mean 3rd party webcam camera. Search for “ new image’ and you should find it. If not I will add the link when I can


#9

@Jim_Scholz I was able to find it. Thank you. To clarify the process you outlined - so I would download both 30.0.3 and 31.0.0, format the SD card and put 30.0.3 onto the SD and insert into the BBB to flash it, then format the SD card again and put 31.0.0 on the SD card, insert it into the BBB and leave it in there? Is that right?


#10

That is correct. That worked for me to fix my unit. I have a hybrid unit with the OROV electronics, navigation and depth sensor, and motors in a homemade shell.


#11

@Jim_Scholz it didn’t take the first time. When you repeated it did you do the entire process or simply keep reflashing 31.0.0?


#12

I have the software on separate micro cards so I can move back and forth as needed to reflash


#13

So you repeated alternating putting both cards in?


#14

No. I loaded 30.0.3 into BB and did the normal update. Make sure that when you are done, the lights are flashing in the proper sequence. If not, run the install into the BB again until it loads properly. After that, put the boards back together and fire up your OROV, then update the OROV board. When that is done, see if everything works. If not, install the 31 board in the BB and LEAVE IT IN and try to run the OROV again.

Jim Scholz
269-208-3465