Going to peru on thurs, need some software advice


#1

Hello everyone, I’m havin trouble loading the cockpit image for the first time. I downloaded putty,I pinged and ssh’d the ip192.168.254.1:8080 without any luck. I installed the image on the sd card and put it in the bbb. I also reset the LAN 192.168.254.5. I know I’m doing something wrong?? thanks for any input!


#2

Hey Zac,

Sounds like your really new to a lot of this, so forgive me if I go to far reviewing the basics:

* Gotta get to step 1, plug the network cable from the topside adapter in to your computer and successfully ping from your computer to the beaglebone on 192.168.254.1.

If your ROV did not come is a SD Card, it is because the image is loaded in firmware. Go ahead and pull out any other SD cards for the initial testing and skip to step a)

If it did come with a SD card, then it is possible something is wrong with it, you mentioned your burned an image on a SD card and are using that. If it is the first time you are using the new image, it needs to sit for about 10 minutes and you have to then reboot as the SD card on first boot tries to expand the image to take up all available room on the SD card.

a) Ensure you can power up the ROV. Assuming you have a recent controllerboard based kit, the top side adapter needs to be powered by a usb cable. Once powered, the ROV should boot. You should see tons of blue and yellow LEDs bouncing around in the electronic chassis. Assuming you have the network cable connected between the topside and your computer, you should also see the 3 leds on the topside adapter all light up and the middle one hopefully blinking.

b) Make sure your computer is indeed using an IP address on the ethernet adapter of 192.168.254.x (where it appears you have chosen to use 192.168.254.5 which should be fine). In windows, open a command prompt and type 'ipconfig' and double check that indeed your ethernet adapter is on the IP address you want it to be on. NOTE: If you also have wireless or other adapters, it is a good idea to go ahead and disable them while troubleshooting. If you had to set the IP address and were already connected, it may help to pull the cable and plug it back in again.

c) At this point, from a command prompt in windows you should be able to type 'ping 192.168.254.1' (no :8080 when you use ping). The system should show you a bunch of lines where it shows it took a few ms to get a response. If it is all timeout message or route not found messages something is wrong. If you get ping requests, you should be able to open a browser at type "http://192.168.254.1:8080" and get the cockpit.


#3

Thanks brian! I’m on it!


#4

Ok I actually got it!!! Well almost. By plugging the usb directly to the beagle bone I was able to connect to the cockpit and download the firmware. When I reconnected the USB to the topside adapter, I can’t seem to get into the cockpit via 192.168.254.1:8080. I pinged and ssh’d via putty the ip, to no avail. The LAN is set to 192.168.254.2. Half the ping requests timed out…is that a sign? I think the Ethernet isn’t finding the beaglebone. Wow, I’m holed up in a hotel with wifi till I figure this out. Thanks for all your help!!


#5

In order to change the local area network IP address you may have to dive into several sub menu's of the LAN adapters configuration. This took me longer than I wanted....