Getting Camera to work


#1

Hi,

I am not getting any video feed through the cameras. I can see the camera in /dev/video0 but nothing coming out of it. I connected the camera directly to my laptop, it works without any issues.

Any ideas on what could be going wrong?

Thanks.


#2

Which camera are you using? some old models do not work.

How is the BB Powered? powering off the USB connector may not be enough power to run the camera.

Also use Google Chrome Browser.


#3

I have tried 3 webcams:

1) Genius webcam (That came with the kit)

2) Logitech orbit/sphere AF

3) Logitch C200

I get no video output in the openrov control panel gui with any of these cameras.

I am using a 5V 1A ac/dc regulated power adaptor to power the BB. I have been using google chrome all along.

Normally I use gui utilities like guvcview or cheese to see if webcams are working. On a completely CLI interface, I could not use them. I tried ffmpeg and avconv cli tools to record videos, but they are not grabbing any frames.

Thanks again.


#4

The problem may very well be with the Power Adapter not providing enough current to power the BB & Camera.

if you have the cape plugged into the BB try applying the 12V to the BB using your batteries.

or try a higher current power source on the usb port. I would try 12V power to the cape 1st.


#5

How do you provide power from the Cape to the BB? Doesn’t the BB need 5V?