Gamepad not working with 31.0.0 RC4


#1

I am having problems with my OpenROV 2.8 after upgrading to 31.0.0 RC4. Using an F310 gamepad (in X mode) that tests perfectly on the HTML5 joystick tester…

There is no thruster control whatsoever using the joysticks, they do nothing. Gamepad button functions work as they should, i.e. lights, laser etc.

Additionally, the keyboard commands for thruster functions only work briefly, the thruster may stutter a bit but then quits.

Any advice??


#2

@lifeboat,

Are you running 31.0.0 RC4 from the SD card or did you burn it in to the BBB?

What brand of computer are you using?

It sounds like you may have a communication problem over the tether. Does the center led in the topside communication unit quit flashing while you are using the keyboard commands to blip the motors?

Are you getting good video from the camera or is it freezing now and then?

Regards,
TCIII AVD


#3

Have you updated the firmware from the cockpit after you updated the software?

Regards,
Brendan


#4

It’s running from the SD card. Is it better to burn it?

I was using my desktop for testing but after switching to a laptop all seems to be working properly. The only “problem” now is 1080 video is too laggy to use, but 720 works well enough. A worthwhile trade off for the improved interface I suppose.

Thanks for the replies guys.

Tim


#5

Hi Tim,

I think the best way to go is to burn it to the BBB (as a backup) and then run it off the SD card. That way if there is a problem with the SD card you can remove the card and run off the BBB. So if you have a software problem in the field you have a backup install ready to go.

Regards,
Brendan


#6

Currently it has the last stable release burned as backup. Not sure how to burn the RC4 as I understand it’s only intended to run from SD. Anyway now that it’s working I’m handing this thing off to a new custodian as soon as possible and will let them worry about it. Thanks.


#7

@lifeboat,

I am running the Pro Camera HD-Upgrade at 1080p on an older laptop with minimal lag the only thing I had to do was reduce the camera GOP setting to a lower value!

However, I did find that my Asus Chromebook will not display the video at 1080p no matter what I set the Bit rate and GOP to.

Regards,
TCIII


#8

Thanks, I will experiment with GOP.


#9

I tried to change settings in Geomux menu for GOP, bitrate, etc. but none of the changes seem to be saved, when I return to the Geomux menu everything is back to defaults. Any advice?


#10

@lifeboat,

It appears that you have to set them every time that you boot up the OROV unfortunately.

Regards,
TCIII AVD