Gamepad F310 no more working-

Have you seen this from michael.bouchaud - 31.0.0-rc7

“Changes are :
Gamepad now works with recent chrome
depth lock work as expected”

Brian, thank you.

    But I am very "novice" to manipulate the soft as it is written

on this mail :

  *            " How to use it, Just download the 31.0.0-rc4

file apply it to the mmc card and update the files with my
repositories (warning on openrov-cockpit* you must checkout the v31.0.0-rc branch). * ??I could make a new image of this if some of you
are interested "*

    So, at this time,?? I am downloading the file on to my PC tower.

    It is done :

    This file : OpenROVSuite_31.0.0-rc7.img.7z - 7-Zip archive

    and ... after ?

    Do I have to open the archive?? ?

    How can go to the MMC card from the PC, something as an IP

address 169.254. …, I think ?

    Which file I have to copy/ replace from the PC to the MMC card ?

    Thank you


Hi Herve,

I’ll be no help with the details. It’d be best to contact the people who posted near the end of the above link who got it to work.


You could try a quick search in the forum to find the way to burn an image file to a sd card.
But you could look too at this link :wink:.
This is about how to update the rov but you could find the way to burn an image to your sd card, no update would be applied to the bbb memory with v31.
For info about v31 version look here New Release Candidate Image ready with 31.0.0 RC



  1. Determine where you downloaded the OpenROVSuite_31.0.0-rc7.img.7z file.

  2. Format a 16GB SD Card with FAT32

  3. Download and install balena-etcher

  4. Start balena-etcher and follow the application instructions to burn the 31.0.0-rc7 image to the SD Card. You do not have to unzip the image file as the burner application will do it for you.

  5. Remove the old SD card from the BBB and replace it with the new SD card.

  6. Apply power and wait for boot up to complete and the OROV Cockpit to appear on your laptop screen.


Thank you very much for your help :grinning:

I 'll do it in a couple of days when I’ll come back.


Have U manage to get your remote to work ?

Not yet, I
come back to my office in 10 days. I am out at this moment.

    Thank you


I had the same joystick problem. I’ve updated to the latest Chrome, and flashed 31.0.0-rc7 to an SD card. When I go to, it now hangs at “connecting to the ROV”, and with, I get a 502 bad gateway error. I think the BeagleBone has booted fine (the blue lights are strobing), and the centre orange light on my topside box is blinking. Any ideas how I can diagnose the problem?


I had the “hanging connection” on earlier versions, in my case the image had not written cleanly on the SD card. You may have already tried this but just in case not, have you tried reloading the RC7 image to the SD again?

While you have lights on the topside box are you getting a response on pinging, with to the .net address or its IP? Does your topside PC get an IP address from the BB?

Below is the original trouble shooter, though using IP address rather than DHCP /

Thanks. Everything working now. I tried a couple of different SD cards, and eventually got it working again with the original one, after reformatting and reflashing. BalenaEtcher didn’t indicate any problems the first time, but whatever the problem was, it’s fixed.

Great, good to hear. I have found RC7 to be stable and with a working gamepad.

Hi all, I havent used my ROV in a year or so and just fired it up and the controller is not working. I have a custom build with strafe control. If I install the new build it will take that control away. Is there something I can do to make this all work? I’m not the most savvy person when it comes to programming but I’ll give it a go. HELP!! lol

Thanks again,

Well I reformatted and reflashed…still no go. :frowning: HELP please.

@BlueRoamer. Saw your strafing ROV build, very nice, if I recall that had some custom code ?

Assume your problem is that the ROV boots ok and works using the keyboard but controller no longer works. Can you confirm what version of Chrome you are on? Previous versions of Chrome worked with controllers but then Chrome changes meant controllers were not working. If you have a later / up to date version of Chrome that could be the problem so you could (re) install an older version of Chrome that was known to be compatible e.g.

If that is what is happening you could set up multiple OS installs on your laptop / PC ? That way you could have one just for OpenROV supporting only the local IP connection - no connection to web, no email or anything, to keep things secure. Stay cyber safe :slight_smile:

Awesome, thanks for the reply, I’ll try that. Yes it does have strafe. Unfortunately I can’t get that mod loaded into the updated build. I think I’ve created more problems. One step at a time trying to get it back. I also have to replace a motor and an ESC.
I come back into the forum and noticed the compact seems to have gone through some big changes. I guess they have dumped the 2.8 and are just making the Trident?

Thanks again, O

Hope you get the controller / game pad up and running so at least you have a functioning ROV again.

2.x is community now. Interesting to see where Sofar are taking things with the recent launch of the ASV (Strider), joining the weather data buoy (Spotter) as well as Trident. Forms a neat network of assets complete with remote access. It would be good if some of the sensors and other addons mentioned for Strider (and I assume will be used Trident) could be utilised on 2.x.

I liked the modular architecture and potential for repurposing that the 2.x boards and ROV’s offered and this is what sold me on OpenRov along with its size. At least the schematics, BOM and other files are available, as well as sw code, given no spares are available via Sofar / OpenROV, as I have a CB out of action following taking some damage by water:frowning: The 5v/3v supply was gone but components replaced on board and that part is working but the Mega / Arduino is dead when probing from the connected and working BB: no ESC supply opened or 3.3v to instruments, so next job is lifting and replacing the Mega and may be the shifter (U7), so fingers crossed that can be done. Have not read that anyone else has done that type of repair. Still nothing to loose.

My ESC’s are ok but I also had 2 motors to change.

Given this recent experience perhaps time for me to get some PCB’s for the CB and IMU made and build myself spares for the future and may be try a build with a 4th thruster as well !

Hi Paul,
Sorry to hear about your damage. It’s one of the things about this sort of rig, it’s not if…It’s when it leaks.

Thanks again for the link. The controller is working. I have just bought the last motor available in Australia. I have a few ESC so hopefully we will be able to keep it going for a bit longer. Saying that, most of the work I do with it is on a 20m umbilical. Worst case scenario if it floods I’ll make an old-school relay board using spdt’s for control and a SDI camera with a DVR to view and record. I currently use a GoPro for back up recording so it’s not a problem to get a really good image. I don’t need the telemetry, so no biggie. The OpenRov saved me from buying a commercial rov for 10m work, it’s paid for itself 10 times over.

Keep in touch, I’m interested to see where you go with yours.

Thanks for the help, really appreciated.


Hi Owen,

Cool, good to hear your build is now working again.

Considering the environment you are totally correct, it is a matter of when rather than if. The components on the CB have been changed out but I am away at the moment so going to be a couple of weeks before I can get round to seeing if I can now connect and installing the bootloader. I’ll post on how the repair turns out.

I do not like throwing things,I aim to patch up, salvage and repurpose as much as possible, so the investment will keep going in one shape or another. I use my dive camera arms and actioncam on the OpenROV - the arms are good for off mounting the external lights.

Apart from the fall back to an spdt’s solution, like a suped up Seaperch, I have been following some other low cost alternatives for thrusters and sensors, even video, depending on what is lost on my OpenROV, the BlueDot looks a useful candidate : Built a New Open Source ROV kit!


I mentioned above some serious repairs were needed to our OpenROV after an incident involving a bit of water, well this is quick follow up post is to say the repairs worked !! I have started off a new topic here outlining what the repairs involved.