Game controler start up


#1

I am having problem’s trying to get my game controller to operate the rov… 2.7
my computer recognizes the controller, I go to settings in the cockpit all the keys work fine for control. I plug in the game controller but no go… any ideas??


#2

You have to press a button on the controller and it should then show a picture of the gamepad near the top, next to the picture of the keyboard.

What controller are you using?


#3

It’s a basic snakebite Walmart cheapO


#4

A few notes for using a controller:

  1. If it has a “mode” button (the Logitech 310 does) you are going to have to play with it on and off. I think it is “off” on the 310, but I forget a the moment.

  2. When you plug it in, @badevguru is correct, you will have to press a button on the controller for the Cockpit to recognize it correctly. I usually press one of the camera up/down buttons (Y or A)


#5

hi Keven
I have a cheap snakebyte controller from Walmart.
I would not know if it has a mode button I don’t play video games, I have pushed each button but the cockpit does not seem to recognize the controller???
I test dove the ROV today goes awesome but I think I could control it better with this game controller.
Any advise would be great.


#6

Hi, I also had an d have difficulties with both my controllers (logitech 510 and 710) they were not recognized anymore by the cockpit. Since updating to the lates version of chrome they are again recognized, but still not working as they should. With the 510 I can control the motors and the servo, but nothing else. With the wireless 710 only the horizontal motors. Kinda frustrating, because last season both controllers worked without any problems.
Hub


#7

Anyone know of a controller that works I have tried two with no luck the cockpit will not recognize them???


#8

Sorry, you’re still having issues. I use a Logitech 310 controller with no issues other than you need to press a button to activate it after your Cockpit has started. I know many other people use the 310 as well.


#9

Man, these gamepads can be confusing! I’m running a Logitech F710 wireless on Windows 7.1 OS, with latest Chrome and stable OpenROV software. On F710, my “Mode” button just switches controls between the left joystick and the D-pad.There is an extra X/D switch in the front that I now think should be set to “X” for Windows, (and “D” for OSX or Mac?).

@Hubertus, I also lost partial control with recent upgrades. I was somehow(!) running acceptably in “D” mode until recently. My follow-up solution was to delete all old instances of "Logitech Virtual HID Device"from the Control Panel/Device Manager, change setup to “X”, or XBox-compatible mode, and use Device Manager to ensure that “Microsoft Common Controller/XBox 360 Controller for Windows” installed successfully. Then, as mentioned above, starting the cockpit and pressing one of the camera buttons did the job.

To @lcapistran’s question, does anyone know whether Playstation 2 gamepads (e.g. his Walmart Snakebite) will work, or is XBox 360 compatibility required?