First test in the field, miscellaneous issues


#1

Hey there,

today i successfully accomplished my first in the field test. First off, it was amazing. Seeing your hand built technology awake to life and use it was very impressive. I want to thank all the people that make this possible!

I however faced some (minor) issues that i need some help with:

  • Finding the correct balance is very hard. I would like the ROV to float just a tiny bit (as a safety measure), but either way it is super sensitive in this regard. Also when I accelerate it automatically does a pretty deep dive. I want to tackle this by reducing the front weight to 2 on each side, but maybe this already too much. Any other ideas?

  • I am using a Macbook Pro, and the software seems to have some issues with multi inputs (for example regarding upwards and forward movement simultaneously). If i read it correctly, changing the controls is only possible via coding in cloud9?

  • I had to finish the dive because the (fully charged) Macbook died after approx. 1,5h. It is a pretty new model and the batteries lasts for 8 hours normally. Is it common that the Chrome application with the OpenROV cockpit uses that much battery, or should i recheck my setup? How do you deal with this measure?

  • I had one issues regarding the upwards thruster, when trying to sink it is a lot stronger than going up, which I would like to be the other way round.

  • The depth (IMU) hold does not work, as it corrects the depth in the wrong way (so if should stick to 1m and it is at 1,1 it starts to sink faster). It was after the dive that i though about inverting the thruster in the cockpit, is it possible to tackle these two issues with this? (I would have expected the software to check this independently)

  • The compass is somewhat unprecise. I read the post regarding its nature, but it seems that the directions change significantly (<90° in 3 mins) which makes it useless for long term navigation. This also regards the heading hold. Any ideas?

  • The tether does not float in non salty water, so it kept strangling on the lake’s bottom, making it a lot hard for the ROV to move. We used some improvised swimmers to keep parts of it afloat, but this does not seem like a long term solution. How is the progress on this matter?

This seems like a long list, but personally i think it is an excellent start and i am sure we can things fix!

Thanks for all the help!


#2

We are glad to hear that you were able to conduct your first field test!

In response to the issues that you faced, here are some notes for some of them.

I use a Macbook as well and while this does seem low, this was about what I got on my first dive. There are ways to extend the battery life past this. First off if you have the ROV connected via ethernet, turn off your wifi and bluetooth in order to save power. Second all of those battery life ratings are assuming that the screen is not on full brightness, but most of the time in the field because of glare the screen is on full brightness. The turn on switch for the ROV is also drawing power through the USB cable. If you run the ROV off of a different power source (like a portable charger for a phone), this will also increase the battery life on your computer. It is pulling roughly 2W.

The software assumes that the thrusters are set in the proper directions. The “shift” button should make the ROV travel up and the “ctl” key should make it go down. It sounds like these may be backwards so it is getting farther away from the target depth not closer.

Are you running the latest software 30.0.3? This was an issue in the previous version but has since been fixed.


#3

Yes, for some reason i have not thought about the usb cable drawing that much power, but this will sure help a lot!

Did you also had the issue with key layout? But maybe this is different for the german key board layout. Where can i find help for changing the keys.

Yes, i am sure this will fix this two matters. I wonder why did thought about this in the field :smile:

Yes, i think i do. (I will check soon) and I will keep monitoring this issue!

Thanks a lot for your help! This will help a ton!

Any more ideas for the tether floating issue?


#4

I have not had a problem with the key layout. Here is how you would change the keyboard commands:

this assumes you are running the 30.0.3 software

  1. Power on your ROV and go to Cloud9 (openrov.local:3131)
  2. Navigate to OpenROV/cockpit/src/plugins/rovpilot/public/js
  3. Open the rovpilot.js file
  4. The code is pretty well commented and you should be able to find what you are looking for. The lines that you will change look like “defaults: { keyboard: ‘z’, gamepad: ‘A’ },”
  5. Save the file (top left corner File>Save)
  6. Open Cockpit (openrov.local:8080) If you had cockpit open already, refresh the page.
  7. The new keyboard commands should be working.

I have a note on my list of stuff to do to look at the power draw of the entire system on a laptop and ways to optimize it. If people have suggestions please let the community know.

For the tether float issue there are some community hacks:


and

I have also used fishing floats and they work well.

We also sell Neutrally Buoyant tether in the store.


#5

I followed your notes and i was able to follow the path to the correct file (both with Cloud9 and Finder) Then i changed “defaults: { keyboard: ‘z’, gamepad: ‘A’ },” to “defaults: { keyboard: ‘y’, gamepad: ‘A’ },” so i changed z to y, this is the control for the camera tilt, and in non english keyboards the y key is below the a key. I saved the file, rebooted but nothing changed with the key mapping (I thought that it was too easy this way :slight_smile: ). Finally I managed to delete rovpilot file, so right now I am reflashing the latest version onto the ROV.

Is there a guide to cloud9 for beginners? I feel that this is a mighty tool for hacking the ROV but so far i do struggle with it.

I am sure using the external power bank will help a ton, and I will give feedback on this!

Perfect, this will help a lot.


#6

It should be that easy. Make sure you refresh the browser window for cockpit. I have also revised my directions above to walk through the process.


#7

I have finally managed to remap the keys as i needed. Starting fresh the instructions worked fine!


Third Dive, making progress
#8

Glad to hear everything worked out :slight_smile: