Firmware upload problem


#1

My issue seems slightly different than what others are reporting with the firmware upload.

I have a new cape which out of the box ran cockpit fine and I was able to control camera tilt and lights via the web interface. (that is all I currently have hooked up). This implies my chip did contain a preloaded firmware. I tried to upload new firmware via the cockpit and got the following behavior:

All of the normal compile stuff scrolled by in the dialogue box and it looked good with no errors. Then I got:

Initiating arduino reset. Shortly after this report led 3 blinks a few times then:
upload failed, trying again. Quickly followed by:
avrdude: stk500_getsync(): not in sync: resp=0xbf avrdude done. Thank you.

Well at least it is polite. These message repeat several times and each time led 3 blinks, and then I get: cat: output.log: No such file or directory. At that point the effort to upload the file seems to stop.

I am not sure what the cape leds signify but during this procedure led 1 is solid green, led 2 is dark, and led 3 blinks as described above but is typically solid red.

Prior to receiving the "factory" cape I had built my own cape and was able to upload successfully to it so I was a bit surprised to have this problem. As a workaround I was going to just pop the chip and put it in an Arduino and do the upload as others have suggested. I decided I wouldn't learn much by doing that so I am going to persist to see if I can figure it out. I did not learn much from Google today but I am not in a huge hurry as every body of water within 100 miles is frozen solid.

I think a sort of end users manual for the cape would be very helpful. Something to explain the leds, the jumper, the unpopulated thru holes, power options, etc. Of course some of this is obvious and I suspect it is all sussable with some effort.

Suggestions, hints, etc? I will report back.

Wayne


#2

Agreed!

  • Would like to know if the Audrino firmware is loaded or not. Or better yet which version.


#3

An update, Issue solved.

I removed the chip and placed it into an Arduino and attempted to upload the firmware with the IDE. Unfortunately I received the same error as I had with the cape. ( avrdude: stk500_getsync(): not in sync: resp=0xbf ) . Using the IDE I also tried uploading the Blink sketch and same error. This leads me to believe the chip which came with the cape has an issue. I replaced the chip with an identical 328P and now I can upload to the cape with no errors.

Wayne


#4

Hi Wayne

I seem to have the same problem. Where do I get the new chip and where do I install it

Thanks