Firmware upgrade failed - can no longer connect to Trident - Help!


When I connected to my trident today it said I needed to update the firmware and couldn’t continue without doing so. I started installing the firware update, but each time it stated "Firmware Maintenance Unsuccessful’. At this stage the app was still connected to the Trident OK.

Switched it all off to do some research here.

On re attaching Trident to the cable/wifi module I can no longer connect the app to the Trident. Just keeps ‘searching for Trident’.
I can connect to the Trident wifi, just not onward to the actual trident. I have checked my home wifi, and the Trident isn’t connecting to that.

The attached screenshots were taken before it lost connection.

On attaching the cable the Trident lights flash like normal, and two of the three wifi lights illuminate.

Please someone help!
I had taken some time off work to use the Trident.

Thank you


@Tim-H Sounds like it’s time to send email to Could you post what they say / do?


Yes thank you, emailed support yesterday. Will let you know when they’ve replied. Fingers crossed there is some way of getting back into the Trident.
Such a good piece of kit usually.

G’day Tim-H,

Sorry to hear about your experience…I can’t help you but I also experienced some issues with the latest update as well.

My software update (33ee7e) was going well until it got to the firmware stage where it stalled on the Controller stage (it was stalled for nearly an hour). When I swapped between apps and then returned to the Cockpit app the firmware screen had disappeared and it was back at the maintenance screen. When I selected ‘Check for updates’ it went through the typical process and displayed the tick and ‘Up to date!’ message. Trident appears to work as normal.

I suspect my issue might be due to the absence of a Controller (I do not have one of the Trident controllers…I use a tablet or my phone).

Good to hear your Trident still works. Mine unfortunately cannot be contacted.
Support have forwarded the issue to their software engineer to ponder.

G’day Tim-H,

I experienced a similar issue whereby I could connect to the Trident wifi but not to Trident itself from within Cockpit. In that case it turned out to be an issue with my tablet controller (my phone connected to Trident and controlled it without any problems at all at the same time my tablet continuously stalled when trying to connect).

Have you tried a different controller device? If your Trident isn’t even connecting to your home network then you might have a different issue however it might be worth a try. The optimist in me suggests Trident might still be OK and might still be working and wanting to dive but that your controller is out of sync and that it has forgotten the home network log-in credentials as a result of the firmware update. The pessimist in me however suggests that you keep in close contact with support.

I can imagine how frustrated you might be feeling after taking time from work to [not] use Trident…I have been there myself.

Thanks for the suggestions, but I’ve tried connecting with a couple of different devices, and all the same. Fingers crossed support have a solution.

@Tim-H What version(s) of Cockpit are you using.

Bottom line - why does Cockpit v1.7.11 think it needs to update the firmware from v1.8.14 (33ee7e) that Cockpit v1.7.9 was already using?

Days before Tim-H first posted, Sofar provided an update for Cockpit to v1.7.11. My tablet was on v1.7.9 and had Trident firmware v1.8.14 (33ee7e). I updated Cockpit to v1.7.11and immediately did the Maintenace -> Check for updates -> Install and it immediately displayed “Update state : DISCONNECTED”

I still had Cockpit v1.7.9 on my phone, did the Maintenance -> Check for updates, and it said the firmware v1.8.14 (33ee7e) was up to date.

Went back to the tablet Cockpit v1.7.11 and it said it was up to date with firmware v1.8.14 (33ee7e). Cockpit was able to control the Trident.

Updated the phone to Cockpit v1.7.11 and all seems fine on both devices.

I agree with @pforperry that something in Cockpit v1.7.11 is initially out of sync.

Is there a list somewhere of all Cockpit and matching Trident firmware releases?

I am still experiencing some minor issues with the 33ee7e update. I have just finished updating two new Tridents and they had the same issue as my original Trident in that the update for the firmware stalled at the “updating the controller” stage. My work-around was to just exit the update process (ignoring the message that suggested I needed to wait for the process to finish) and then re-start cockpit. It is always a bit unnerving to exit part way through a firmware update however in this case it seems to have a good outcome.

For interest sake my original Trident continued to work well after the issues I had with the update so all was well that ended well…until one of the horizontal thruster motors failed and until I cannibalised the vertical thruster for another Trident user here in Queensland.