Firmware download for the arduino interrupted


#1

Hi I need some urgent help
I was updating the software for my openrov v2.8 and as I reached the final step which is updating the firmware of the arduino from the cockpit the webpage became irresponsive so I killed the page (the progress bar was full at the time but no message was shown about the firmware update being completed). When I tried to repeat the firmware update I couldn’t reach the cockpit, the browser is saying that this site can’t be reached. The only LED working on the controller board is the PWR/LED1 and non of the LEDs of the beaglebone are working.
I repeated the whole process of formatting the SD card then burning the image to it and downloading it to the beaglebone but its still the same.


OpenROV software intern interested in ROV computer vision projects
#2

I actually had the same problem as you a few days ago, and performed the same troubleshooting steps. I was able to connect the beaglebone black to the PC (separate from the controller board) and confirm it would boot up. My issue was that there was not enough current to power the components and the firmware update died halfway through. I replaced the power supply, and once I was able to apply enough power, I turned the components on (with a fresh image on the BBB) and waited for about 15 minutes. Eventually the controller board was able to get to the cockpit, but I may have been very lucky though.