Ffmpeg fails to install


#1

Hey guys,

I have been fighting with the Beaglebone for a few days now and have finally got to the install of ffmpeg... here is the catch ... i keep running out of memory and crashing!!!

CC libavcodec/h263.o
CC libavcodec/h263_parser.o
CC libavcodec/h263dec.o
CC libavcodec/h264.o

cc1: out of memory allocating 16989064 bytes after a total of 80052224 bytes make: *** [libavcodec/h264.o] Error 1

Any ideas?


#2

Which build instructions are you following? I think I ran into this when I was following the build instructions for the master branch. I've since switched to the development branch and got much further.

I did run into some problems there too and Dominik has been helping me. In the meantime, I've thrown everything I know into a new wiki page: http://wiki.openrov.com/index.php/Installing_The_Software

Warning! It's very rough. Please keep notes and edit it if you try to follow it.


#3

I actually ended up following the ozbots version and it went off without a hitch. The issue seemed to be with the newer versions of ffmpeg - as far as i can tell (i havent had a chance to test it) OpenCV installed correctly and i am most of the way there!!

I think i have been working with it for the last 4 days off and on - longer than most of the ROV itself! haha

I will verify what version of ffmpeg worked and post again