Everything works except LED light?


#1

Everything works except the LED light?
I have the old ROV cape, which I have loaded manual.
there is a fine picture and servo / esc work as they should.
but I can not turn on the LED light?
Is it something with the pin number to do?
I'm not so good at this code thing;-)
Is there someone who can help ..


Thanks


#2

Hey Thomas,

Can you send a photograph of how you have everything connected. That might help debug any problems with wiring. Are you pressing "P" on the keyboard to activate the light?

E


#3

Hi Eric
I've tried pressing "p" but nothing happens?
I have taken the cape out and laid it on the table,it works except the LED light.

There does not seem to be something wrong

Thomas


#4

Hi Thomas:

If your wiring looks to be good, then you're going to have to do a little investigation on the Cape itself. Make sure you have the schematic for the Cape; you can download it here.

First try putting a voltmeter across the LED wires where they connect to the Cape (P11).
You should get some voltage there when you are trying to run the LEDs.

The LEDs are powered by the Cape +12V power supply. You can check that the +12V supply is working by putting a voltmeter between test point TP3 and Ground. See sheet #3 of the schematic. TP3 is located in the center of the Cape, on the top side.

Let us know how that goes.

-W


#5

Hi Walt
I have tried as you described, there is 0 volts (0.085v) across LED wires
and 12 volts on TP3.

Thomas



#6

Okay, that's a good first step.

Now we need to see whether the software is actually turning on the PWM channel. Measure the voltage on Pin 11 of the Atmega chip (signal is PWM1 - see schematic sheet 4). Although the Atmega chip is on the bottom of the cape, its pins extend through to the top. But it will take a bit of thinking and looking to figure out which one is pin 11.

When you turn the LEDs on in software, you should see a voltage on pin 11. For the LEDs full on, this voltage should be 5V.

If you get voltage on Atmega pin 11, then perhaps the LEDs are shorted somewhere. Try removing the LEDs and remeasuring the voltage where the LED wires would hook up to the cape ( connector P11).


#7

There is 0 volts at pin 11

and nothing happens when I press " P " and +/-




#8

Hi Thomas:

Now that's really interesting.

Okay, lets take a look at the software side of things. When you press P and O, does the bar graph for the LED in Cockpit move right and left?

Also, what software are you running on your cape?

-W


#9

Hi Walt

Nothing happens with P and O?
software on the cape is v0.9.

Thomas


#10

Try upgrading to the latest image. You can get it here.

-W