ETS balun and Ethernet autonegotiation


#1

I am having a hard time trying to connect the BeagleBone via the baluns (that came in the kit) and tether to a Gigabit or Fast Ethernet switch port. According to the logs the link is coming up at 100 Mbps full duplex -- but the baluns only work at 10 Mbps. The board could establish a working link with a 10 Mbps-only PCMCIA Ethernet adapter.

I tried to use ethtool to force the BeagleBone to use 10 Mbps, but the device driver for the PHY on the board does not appear to support the operation. I suppose I can do the same thing at the other end instead if it is an Ethernet port on a PC (if this is what everyone should do then maybe it can be described in the docs), but I would like to use a (dumb) switch port when I test the board and software.

Does anybody know of a better way to avoid speed negotiation when using the baluns?


#2

Hey Kensaku,

If you're at this stage, I strongly recommend upgrading to the Homeplug Adapters. We've upgraded all of our ROVs and it's MUCH faster and more consistent. You can read more about the build here:

http://openrov.com/forum/topics/teardown-of-a-homeplug-adapter

You can order them on amazon here: http://www.amazon.com/Medialink-HomePlug-Powerline-Ethernet-Adapters/dp/B004UGPCMQ

We'll have updated build documentation up next week with the process for the medialink homplug adapters.


#3

Hello David,

I see. Since I live outside the US it's difficult for me to get hold of an adapter of that particular model. I will try to see if I can find something sold here in Japan that I can use for the purpose. Thank you.


#4

ok, we'll keep looking too. Eric mentioned a few other suppliers that have similar products. I'll ask him and get back to you with more links!


#5

Hey all!

If you live outside the US, this product:

http://www.tenda.cn/tendacn/Product/show.aspx?productid=407

Is the same thing. We just got one at OpenROV HQ that we’ll test out, but so far they look identical.

All the best!

Eric


#6

Great! These are being sold on eBay, worldwide shipping available. Just now I ordered a pair.


#7

I’ve built mine using those and they work fine, over 100m twisted pair


#8

Hello,

It seems you know how the baluns work. I am trying to assemble and old openrov version I have found (I already have my 2.6 version) and I am having problems to connect the ROV with the computer through the baluns, I wonder if you know why could this be happening. I don't find any documentation of old OpenROVs.

What did you meaned with forcing the computer tu 10 Mbps? you still think this should be done for connecting through the baluns?

Thank you a lot

Regards


#9

Yes, I believe you should be able to use the baluns if you force the connection to 10 Mbps speed. However you may want to consider following David’s advice and modify the unit to use Homeplug adapters – they are both faster and more reliable.

The problem is this: the BeagleBone board inside the ROV supports 10 Mbps and 100 Mbps connection speeds, while your computer usually supports 10 Mbps, 100 Mbps, and 1000 Mbps. The baluns work reliably only at 10 Mbps. Normally the speed of the connection between the two machines is determined by auto-negotiation; however the auto negotiation protocol apparently does not notice that the baluns are capable of passing only 10 Mbps. So the link between the BeagleBone and your computer comes up at 100 Mbps (the fastest supported by both ends), and communication fails.

So you have to configure one end of the link to use only 10 Mbps (the other link will follow automatically). Initially I tried to configure the BeagleBone side but found that it was not possible. So you have to configure the computer side instead, using one of the following methods:

  • If your computer is running Windows, change the properties of the network adapter. For example on my computer I can change Device Manager -> Intel® 82567LM Gigabit Network Connection -> Advanced -> Link Speed & Duplex from “Auto Negotiation” to “10 Mbps Half Duplex”. (The name of the adapter and the name of the property will probably be different on your computer.)
  • If you are running Linux you can use the ethtool program.
  • Obtain an ancient Ethernet adapter that supports only 10 Mbps, and attach it to your computer. (This is what I tried.)
  • Place an Ethernet hub or switch between the computer and the ROV, which supports only 10 Mbps or can be configured to use only that speed.

#10

I've just try, but it doesn't work anyway... it may be another thing. The leds of the beaglebone and the controler board are on. So I don't know what could be the problem.

Thank you a lot.

Javi


#11

Hi,
I am a HomeplugAV developer and I suggest you upgrade to a 100 Mbps or even a 1000 Mbps if you decide to stream multiple videos from multiple cameras. I have tested 6 HD video streams so far with no issues.

You always want to auto-negotiate your link speed.

I would more than happy to answer any additional questions.

Inti


#12

I followed the thread on the “teardown of a homeplugav adapter…” it works great I tried with 2 different adapters. TPLink and Netgear on unshielded twisted pair. I will try and do this on latest generation of powerline QCA 7500 1000 Mbps with MIMO technology. Basically we put 2 tx and 2 rx on the adapter and utilize more the channel.