ESC's wont' keep programming

propulsion

#1

We've been having ESC problems from the beginning. We've had to reprogram them pretty much every single time we boot the ROV up, so we decided to completely replace them, unplug everything, reprogram them, and yet they still lose their programming. Is anyone else experiencing this? What could be causing them to constantly freak out on us?


#2

Hey James,

Can you describe the symptoms by which they seem to loose programming? Sometimes the Beaglebone and the Arduino can have corrupted communication and the Arduino might miss some of the configuration data in which case the motors won't behave correctly. (This was more of a problem in some of the early Release Candidates of the pending release but it is non the less a potential problem in all releases).

-Brian


#3

Sure - from the start, the issue has been that the props would behave erratically, spinning when they're not supposed to, or not spinning when supposed to, even after having been programmed. So after replacing the ESC's completely, unplugging the camera/servo, and reprogramming them, we're noticing two things: first, they still lose programming regularly, and second, that anytime we have the Thrust level at 1-3, everything works OK, but once we get to 4 or 5, stuff stops working. For instance, in reverse, the props will spin for about a second, then both stop. Using multimeters we verified that the voltage stayed constant to the ESC, but the ESC wasn't signalling the props to spin and they'll just stop. Or when doing turns, one prop will keep spinning but the other will stop


#4

Okay. Can you confirm that you did both the (1) Programming step and (2) the calibration step? A LOT of people have gotten confused that there are two separate steps.


#5

Oh yeah, that's a valid question, but I can confirm we've calibrated after programming properly. Ever so many times. I have the programming and calibration steps memorized at this point, sadly enough.


#6

Hi James:

What software load are you using? There was a bug in some of the earlier builds where high thrust levels in reverse would cause the motors to stop, due to the way that propeller efficiency corrections had been implemented in software. That sounds to me like what you're seeing- the motor is accelerating to speed in reverse, but then stops because there is an overrun in the software.

If you go to the releases page on GitHub:

https://github.com/OpenROV/openrov-software/releases

and look through the release notes, you'll see that this bug was fixed in the final release of 2.5.0. If you're game, try downloading the latest release candidate of 2.5.1 (RC5) and giving that a go.

-W


#7

We're on 2.5.0 right now... What's weirdest of all these things to me is that the ESC programming keeps getting lost. I was not expecting that to happen after we replaced the ESC's but even with brand new ESC's the programming gets lost. That can't be right.


#8

It is more likely that something is off with the settings in our code that make it look like the ESCs have lost programming.

If you reset the ROV does the problem go away, at least temporarily?

Per Walts comment, we have a bug in the 2.5.0 software that going full speed in the reserve direction actually causes us to send a motor signal beyond the range of the ESC resulting in full stop.


#9

Well, we went ahead and put 2.5.1. rc3 on an SD card and booted it up and noticed the problem went away, so it appears to be a software issue after all. We flashed to the ROV and noticed that the ESC's continue to lose programming. However, once programmed and calibrated again, the ROV performs as expected now.


#10

I been reading a lot around the forum about the ESC Programming and Calibration, and Nothing seems to solve my problem.

I could really use a little help here.

I made this video about the problem that I'm having, I already update to RC5, program and Calibrating the ESC around 30 times already. And I'm stuck.

http://youtu.be/wifkVtUw7GM

I saw you giving many advice to other fellows in the forum, so I'm waiting for your enlightenment.

Thanks in advance!


#11

Hi!

I just got my OpenRov and I've got the reverse motor issue. I Upload to the 2.5.1 RC5 and happens the same thing. Everything works great until y hit reverse or vertical thruster.

Is it any way to test the ESC, I will disconect all and try them one by one, to check if there's any difference between them, they can't be all corrupted.

Any other options to solve this problem?

Thanks in advance!


#12

Hi Cristian:

I tried watching the video but I can't really tell what's happening on it. I see on the post below that you are having some sort of issue with reverse and with the ESCs losing programming. Can you give a fuller explanation of the symptoms that you are seeing?

Thanks,

-Walt


#13

Hi Walt!

So... I got my 2.6 kit like a month ago and took me 3 days to assemble the entire thing. but since the first start up, right after Programming and calibration of the ESC, I been having this issue: I press forward (up arrow key) and both (port and starboard) thrusters spin in the opposite direction "Thrusting" forward; I can control speed with the numeral 1-5.
BUT when I press back (down arrow key) the only motor that changes the spin direction is the Board one, thrusting backwards how is supposed to do. While the Starboard motor remain still; and then the red and green light from the ESC stays on and the only motor spinning (either forward or backwards), is the Board one. Until I switch OFF and ON from the ESC.

The third motor, doesn't work at all and I lose the Tilt servo also, it was working before but I don't know what happened to it.

I tried using different laptops, but ended up with the same results.

I have a spare Control Board, so I moved all the components there, and I tried to make it work as it was, software/firmware factory default, and check the ESC programming and calibration, but the same thing happened.

I tried email OpenRov Staff, to order components to replace/update to 2.7 but no reply.

And I really want to make my ROV dive, because its going to be 2 months and zero dives and since is not diving I can't test any of the modifications and instrumentation I'm planning to equip my ROV with.

Thanks for your interest!

Best regards.

Cristian_