Dive lights flashing, no other problems


My new-built 2.7 unit with 30.0.2 software starts flashing the camera lights a random time after the cockpit starts - seconds to a few minutes. There is no other problem - I still have full control over everything and therefore it doesn’t seem to be a communications issue. I can’t find a way to stop the flashing.

Blinking Front illumination Leds trouble connecting to HUD
OpenROV IMU 2.0
[SOLVED] Can t connect to my openrov using chromebook

This is a known issue and we are working on fixing it. If you would like to follow the progress check out the open issue for it #438.


Hi. It would seem the problem is still on-going

I an running version 30.0.3 and using windows 10.

This is only my second time of powering up my ROV. First time I had no problems at all. This time, I have had to
change my IP address twice. The symptoms are exactly as you described in #438


@martinoliver_999 are you using a direct connection to your computer or are you using an ethernet to USB adapter? Also in the bottom left corner of the cockpit screen there is a latency counter, what is your average latency looking like?


Thanks for coming back so soon Brian,

I am using a usb ethernet converter as my new laptop doesn’t have a direct connection. The converter is also a usb hub and I connect the gamepad and topbox into it.

The average latency is between 10 and 40 when the system ieven when the lights flash. I still have control of other functions during this time.

I have noticed that the topside box has a flashing homeplug connect led , and having just moved the gamepad and topside box usb connections away from the ethernet converter makes no difference.

If it helps, when I have flashing dive lights I have no dive light control, no laser indicator and the camera angle indicator stops functioning. The power and dive time indicators also freeze and on checking now the system down time is exactly 4 or exactly 6 mins against its normal function time of exactly 2 mins.

You mentioned in #438 about disabling the time/date. How do I go about that? I am willing to try.


This issue of them flashing when they were not supposed to be was solved in the 30.0.3 release. When you updated your software on the BBB did you also update the firmware on the arduino? Step 15 and 16 of this guide.

It sounds like the flashing lights are getting triggered because you have an actual issue with the connection and they are alerting you of this (the purpose of the flashing).

During the time that the dive time freezes do you still have video? Also when this happens what it he CPU usage at (the percentage at the bottom by your battery indicator)?


Thanks Brian.

This is a new build and I have not yet re-flashed the bbb. It could feasibly be that the image on the board is an older one. I assumed that the sd supplied with the 30.0.3 image was as on the bbb.

Your very detailed and well explained instructions mean that I could try an update and see if that resolves the issue.

For interest, There is normal video when the lights are flashing. I think the cpu usage freezes, but has been about 25 to 45%.

It will probably be a few days as I am on long night shifts for the next few weeks, but I will let you know the outcome. Our model boat club has a submarine day in two weeks and I am hoping to show off the OpenROV, but only at its best.

Kind regards



We switched the software on the BBB to 30.0.3 as soon as we could after it was released. We did our best to make sure that the controller boards had matching firmware. A quick check of the software (scroll over the OpenROV logo in cockpit to see the software version number) and then a re-flash of the firmware to make sure it all matches should give a good starting point where we are on the exact same page.

Another thing to check is that your tether is firmly in the topside adapter. Make sure that you push the orange tops back to open the inside of the adapter to clamp onto the end of the tether.

Hopefully the ROV is fully up and running by then!


Hi again Brian,
Well, the latest is that the cockpit version I had was v30.0.0
I believe that will explain all the problems I had. However, since flashing the bbb with the v.30.0.3, I have been unable to connect to the cockpit via the normal route.

I have picked up the threads on the forum and plugged the ethernet cable direct from the laptop into the bbb. The cockpit comes straight up and all works fine. Through this route I was able to confirm the update version of the cockpit and then update the firmware on the Arduino. This would tell me that the homeplug connection is a new problem.

I have reseated both tenda boards and ensured the internal ethernet cable is properly seated. I have all three lights on at the topside box and both lights on beside the ethernet cable connector on the bbb. I have tried numerous changes to the IP address last number, to no avail. I have also confirmed good connection from the terminals on the topside box through to the D-connector.

I have run through the troubleshooter to ping the ROV and in the end it refered me back to support as a problem.

As I believe we have resolved the initial problem, and found a new one, did you want me to end this thread and go via the alternative support route?


Glad to hear that the flashing lights fix in 30.0.3 was able to solve your problem.

In terms of the problem you are currently having we can keep it here for now in case anyone else is following this thread. If it starts to get to complicated we can move this to our support channel.

If you remove the static IP address from your computer and set it to automatic and in google chrome if you use openrov.local instead of are you able to connect?


Thanks Brian

I’ve now tried setting to automatic IP address and searching using “openrov.local”, I got 16,900 results. Nothing initially looked helpful. I searched “openrov.local” and tried it with either “:8080” or “:3009” as a suffix. Both tried to connect but failed with the message that “the server DNS address could not be found”. The normal message is that it “…took too long to respond”.


If you open up your terminal (“cmd” on windows) and type

ping openrov.local

are you able to get packets through?


Hi Brian,

Positive news here. I am away from home at the moment and I brought the ROV with me. I have had a session where I chamfered the tube ends, put plugs on the Neutral buoyancy cable, etc.

Today, I did as you asked and pinged “openrov.local”. It worked. I got a return signal. Which made me then try and connect to the cockpit via Chrome. That worked instantly.

I am still not sure what was wrong, and using my engineer (mechanical) head, I’ll explain my set-up.

OpenROV 2.8 running v 30.0.03 cockpit.
This runs a two wire connection to the topside box.
(The connection is via exchangeable standard twisted pair cable - 100m and/or neutral buoyancy cable - 15m. Terminated at each end with belkin waterproof connectors.)
From the topside box, I run a usb cable and an ethernet cable to a USB multifunction hub which also has the F310 gamepad connected.
I am running this set-up on a HP stream laptop on Windows 10, which I have set the ethernet connection as automatically selected.

Regarding my connection problem:
I still have no idea what resolved it. The cable was giving good connection signals to the led’s. It was physically checked with a multimeter. For testing and set-up I plugged the ROV direct to the topside box, so there should have been no induced interference. The odd thing is that the initial trial was away from home, in the same place I am now. I shall see what happens when I get back, but I can see no obvious cause at this time.

I will say however, I really appreciate the continued help from OpenROV via the incredibly detailed build guides, the forum, troubleshooter guide, store and DM when I visited you to collect the kit. There are few businesses that provide such accurate, knowledgeable and friendly support. Please give yourselves a pat on the back.

I shall try the set-up again when I get home, Brian, and let you know, hopefully, that #2630, “Deepsee 2”, is up and running in the UK.

Thank you.

1 Like

First off, thank you @martinoliver_999 for the very kind words about our product support. We strive to provide the best support we can for our products and it is always nice to hear that we are succeeding.

Second, the reason you are able to connect is that instead of setting up a manual network connection it is all sorting itself out. With the 30.0.3 software release we implemented something called mDNS which allows for your computer and the ROV to automatically see each other and resolve the IP address. You can read more about this with a quick Google search or in this Wikipedia article.

Finally, I wish you all the best and and I can’t wait to see what great things you are now able to explore with Deepsee 2. As always, if you run into any additional issues in the future please don’t hesitate to reach out to us.

1 Like