Dazed and Confused


#1

A brief history: My 2.5 arrived 6 months ago and I completed physical construction by about February. I got to the point that everything was working, but I couldn't get a good seal so I couldn't launch it. I built version 2.6 end caps, which entailed redoing the DB25 connector, etc., and have not been able to get it to work since. I can connect to the cockpit and do see a video image, but have no control over any of the motors or the LED's (I have not installed the lasers). I have tried countless times, as recently as 30 minutes ago, to update the arduino, but everytime it gets a synch error and fails. I see that others have that problem, but infer from another post that the cause may have been bad code which was replaced within the last day or so. I have tried reinstalling the new code without success -- I still get the synch error arduino update failure. My cockpit view has changed, however, which suggests to me that at least the beaglebone got updated, but I am not sure that is possible since I was using the update from the SD card, not the new flash method. Until recently, my cockpit showed 0 volts. Now it shows a red battery icon but no numeric value. I have verified that my batteries are fully charged, and I have investigated the possibility that I have a short in my DB25 wiring. To that end, I purchased a gizmo that helps analyze DB25 connections; from what I can tell, the only continuity between adjacent pins is explained by continuity in motor windings. And I did verify that I am getting full voltage from the batteries through the correct pins at the correct polarity. Still, I am tempted to buy another end cap set and rewire the whole thing. If I do, I will solder up the db25, and test those connections, before making further connections to the motors, etc.

Frankly, a big part of my problem is my own lack of ability to understand the instructions I am reading on this site. In an effort to remedy that, I purchased a book on beaglebone and a book on arduino, and have spent the last 3 months trying to become conversant in those concepts. Unfortunately, even though I have learned to make both the beaglebone and the arduino do simple things like flash leds, nothing I have learned explains most of my questions. My confusion is everywhere, but as examples, I see references to cockpit and dashboard, but I can't really understand the distinction. Similarly, I read about needing to boot the beagle bone twice after "all the lights go high" but I am not sure I am doing that correctly. I have looked at lots of youtube videos, but haven't found one that addresses the software issues I am having.

At this point, I don't know what to do and am looking for suggestions. Thanks, Rick


#2

Hi Rick

By the sounds of it you had everything working at one point in time so I suspect that the BBB & Control board are working or were working. You can get video even if the control board is not working correctly so we need to determine if the control board is in fact working.

How are you powering up the ROV? are you using +5v over the tether to power it up? or are you jumpering the pins on the control board to bypass the homeplug adapter power up feature?

In the cockpit do you get any telemetry on the right side of your desktop.


#3

I am using the tether for power. I would like to try jumpering, but don't understand what to do. I take it I have to attach a wire to J17 (as I recall), but where does the other end go and don't I need to provide ground as well? No telemetry on right side. Sorry my questions are so basic, but thank you for your patient and repeated help. -Rick


#4

OK if there is no telemetry then the control board sounds like it may not be operational.

There are two jumper locations J11 & J17. Each one has two pin holes that you can either solder pins into, then just jumper or short the pins together at each jumper location, or use a jumper wire. This will apply power to the control board and BBB. Because you are getting video that is telling me that the control board is supplying +5v to the BBB and also 3.3V is powering up the Home Plug adapter but it is worth a try to jumper those pins. J17 supplies power to the ESC's

The ROV should work on just one battery pack so you can try using one to make sure it is wired up and working ok then try the other side by itself to make sure it is working ok.


#5

also another test would be to see if you can program the esc's if so then you know you have +12V going to the ESC's


#6

David, thank you so much. I will try it all, hopefully over this long weekend.

Thanks again! -Rick

By the way, I bought a stand alone BBB -- if your advice above doesn't work out, maybe I should try to swap out somehow?


#7

Your BBB sounds like it is working ok if you are getting Video.

Good luck.


#8

Rick, I've been thinking a lot about your predicament but am a bit stumped about what's going on.. would you be interested in hopping on a call some time? Email me at eric@openrov.com if you'd like to set something like that up.

-Eric


#9

I suspect this issue will come down to downloading the Ardunio code. There have have been a few threads related to the issues of downloading the Ardunio code for various reasons. you may wish to read up on a few.


#10

Hi Eric,

Sorry for the delayed response (I was away without internet all weekend). I would very much appreciate your telephonic assistance and will email you.

Thanks, Rick


#11

Hi David,

I was away over the weekend without internet access and did not get any time to try the suggestions you made earlier. I have read a bunch of the arduino threads and invariably get stuck because I do not fully understand the instructions. For example, I see that there is a file (active.h., as I recall) that has a line that must be changed and I have not been able to find that file anywhere).

In any event, I will begin with the instructions you gave me previously.

Thank you for your help and patience.

Regards,

Rick


#12

David and Eric:

First off, I jumpered J11 and J17, and then rebooted -- nothing worked, no lights on BBB or the control board or the ROV side of the homeplug adaptor. So, I put an RS232 Breakout Box between the control board and the DB25 coming from the end cap. When I have the 4, 5, 6 & 7 pins turned off, I get 12+ volts between 4 & 5 and between 6 & 7 (and polarity is correct). I also have 5 volts between 18 and 19. When I turn those pins on (and all the others off, effectively disconnecting the motors and spares, the voltage drops to almost zero between 4 & 5 and between 6 & 7. So, it sounds to me like I have an on-board short.

To diagnose, I removed the jumpers and tried again. All the lights are working again, and I am back to where I was -- I can connect and have video but no telemetry and no lights, no motors and no tilt servo.

My guess is that I have an on-board short, which fried my power switches. So the batteries don't get connected without the jumpers and there is enough power for the BBB and control board to boot up. But when I jumper that allows a short and drops the voltage to the point that nothing can boot. Assuming that is right, I need to find the short. I inspected everything (and it can't be on the DB25 or outside anywhere on the outside of the shell (if that is the correct term), since I have effectively disconnected all of that with the RS232 Breakout board. I suspect the short is in my wiring of the ESC's, but I can't see any stray wires, and this used to work. Perhaps the problem is internal to the ESC's (or at least one of them)? I am highly tempted to buy a news control board and new ESC's and give that a try.

Any thoughts, suggestions, questions, etc. are greatly appreciated.

Thanks,

Rick


#13

Hi Rick

I see that I mentioned to jumper J11 in Error and I thought that I had replied to correct that error but it looks like I may have done so to a different thread. It should Have been J12 & J17.

If you jumper ed J11 that would short +12V to Gnd. So sorry for that error.


#14

*****************************************************

Important to those reading these Posts!!!!!!!!!!!!!

An ERROR was made to Jumper J11

This is the AUX input power and if you did that it would short the +12V rail to Ground.

DO NOT JUMPER J11

J12 is the correct jumper to turn on the power for the control board.

*********************************************************************************


#15

Hi David,

No problem -- it is actually good news because I don't know how I would have found the short otherwise. So, I will jumper 12 and 17 and see what happens.

Thanks for your help, and please let me know if you have any thoughts in the meantime. (I probably won't have a chance to work on this again before next weekend).

Regards,

Rick


#16

Success!!!

David, I took your advice and unjumpered J11 and jumpered J12, then rebooted.

No change, -- as before, only camera worked, no lights, etc.

So, I tried to reinstall the arduino code, and that worked first time. Even so, the lights, etc still did not work, so I rebooted, and BINGO, everything works.

That leaves me wondering about the jumpering -- I guess that means that I need to disconnect the battery end caps after every use in order not to run down my batteries? Is there any alternative? Sounds like I should probably buy a new controller board if the hassle factor is too great? Or maybe I will find a say to incorporate an magnetic swtich?

Thanks for your input. Eric, thank you for offering a telephone call -- if this had not worked that would have been my next step.

So now I need to program and calibrate my servos, then it should be time for a test dive. Perfect time of year, too, since I will be heading offshore (California Channel Islands) in a couple weeks.

I will try to do the servos on my own, but may need to ask for help with that too.

Regards,

Rick


#17

Great to hear that you have had some success and are now at a point to test your ROV. Now comes the question as to why the ROV does not power up when jumpers are removed. If for some reason you do not have +5v going across the tether then that would prevent it from powering up. You could try using a volt meter and measure the voltage across the tether input to the ROV and it should measure +5V if the topside adapter is working correctly.


#18

I have confirmed that I have 5v between the two DB25 pins that correspond to the tether, from the topside adapter side of the DB25. (The RS232 breakout box I bought just for this is very convenient.) But, I will double check that.

Thanks again, Rick

By the way, should I be able to boot up without the batteries, or does it take the batteries and the tether?


#19

Hi Rick

You would need the batteries installed in the ROV.

The +5v on the Tether just energizes the electronic switch on the ROV control card which turns on the +12V from the batteries which is used to power up the control board & BBB.


#20

Hi David,

Just wanted to share my resolution with you as it may help with others in the future. Once I jumpered 12 and 17, I had power to the motors, but more importantly, I was able to successfully upgrade the arduino. At that point I programmed and calibrated the motors without incident and could readily reboot and have everything work. Then I removed the jumpers, and guess what -- everything still works. So, it seems that the jumpers facilitated my successful software upgrade/reload, but were not necessary afterwards.

Now I have to up it all back together and give it a test swim -- this weekend, hopefully.

Thanks again,

Rick