Current development branch node.js code doesn't work with latest express module (fixed)


#1

The current version of the node.js module express (a framework to build websites/apps) you get when you do npm install express has changed its syntax slightly.

This makes the current OpenROV code not work (not serving any static files and socket.io doesn't work.

I fixed this on a fork of the current OpenROV development branch (https://github.com/codewithpassion/openrov-software/tree/openrovDev) and created a pull request: https://github.com/OpenROV/openrov-software/pull/6

Until the pull request is included, anyone who just build node on their BeagleBone might wan't to apply that pull request or get the code from my fork.