Controller board v2.6 issue and leds


#1

Hi everybody,

I am facing some problems with the controller board.

At the very beginning, the controller board didn’t work until I plug in the USB cable of the top interface board. Now the arduino is running and Beaglebone black without it the led power and RX are on (Led4 is flashing). I dunno what happened but it is supposed nothing get work without plug in the USB cable! Any thoughts?
And now the leds aren’t working anymore I don’t know why how many time I keep trying “pressing i, o and p” nothing work when apply a direct power for the leds it works very fine but I don’t know why isn’t working with arduino.

Thanks!
268-20140819_115735.jpg (2.82 MB)
269-20140819_115944.jpg (2.33 MB)
270-20140819_120454.jpg (1.69 MB)


#2

Hey Ahmend,

Sorry, the description above is a little confusing. It seems like your reporting that you cannot get the controllerboard to power on unless you apply power to the beaglebone via it's usb interface. Is that correct?

Please note that the controllerboard has a power switch that won't turn on unless there is 5V across the tether. That happen automatically when you power up the topside adapter. You can bypass the switch by shorting J12 if you need to.


#3

I am sorry for the bad description. I will try to clarify my questions.

Issue no. 1

The Arduino and Beaglebone switched on when I connect the power source even though it didn’t use to automatically power on like that. It is used to work when I push the usb cable of the topside interface on laptop and switched off when I pull it out.

Issue no. 2

Array leds are not working "high power leds"
They used to work normally from the cockpit by using i, o and p Keyboard Buttons.

I checked them on direct power and it worked. I don’t know how to make them work again. I uploaded the firmware of Arduino so many times but they aren’t working.


#4

Okay Ahmed,

On issue #1: If I understand correctly, the ROV is powering on the instant you have batteries attached even though there is no USB powering the topside adapter. The "switch" from the topside adapter seems to be stuck "open". Correct?

If so, I would start by checking for a short in the wiring harness. Try measuring the voltage between the tether wires when it is supposed to be off but is still on. If you get any meaningful voltage then check your solider points in the DB25 adapter for tiny strands of wire that might be bridging across two of the wires.

I suspect issue#2 will be a side-effect of Issue#1.

-Brian


#5

Hi Briar,

Nothchanged I have checked the wires and it seems everything is still the same and nothing worked.

I attached a photo it shows that light indicater iS
On and the same of topside interface it looks like it is short circuit.
272-20140821_204446.jpg (2.98 MB)
273-20140821_204356.jpg (2.79 MB)


#6

By the way I am using a dc power supply 12v.


#7

I checked the values displayed on cockpit. It shows the light goes between 0 to 255.

I put the light cables on p2- and p2+ and it shows feeding light of course it's 5 volt not 12 volt.

any suggestion ?


#8

Isn’t it strange? Please take a look at the attached photo.
271-20140827_233804.jpg (2.1 MB)


#9

Ahmed:

As Brian said above, have you measured the voltage between the DB-25 pins used for the tether when you have your 12V power supply on? If you don't measure any voltage between them, then go to Optocoupler OC1 and measure the voltage between ground and each individual pin (there are 4 of them) on the optocoupler. Let us know what you find.

-W