Constant resetting of ESCs


#1

I have a 2.7 that has developed an interesting issue: The ROV boots up with the initial tones from the ESCs and then the final tones once the ROV has booted. Approximately 30 seconds after that, the ESCs reset and I lose motor control. While diving it will randomly reset and I lose motor control for ~15 seconds. In a 20 minute dive, it will do this anywhere from 5-20 times. I have tried the 2.5.1 firmware and the 3.0 with no difference, so that makes me feel that it is a hardware problem.

I have tried to have the serial monitor open to try to watch what is happening to cause this, but it is like drinking water from a firehose. I have not been able to find a main log file to try to figure out why they are resetting, am I just looking in the wrong places?

Anyone else have this issue?


#2

Hey Paul,

In the lower right you have a runtime above the system time. Is that resetting back to zero when the ESCs reset? If yes, then the Arduino is resetting. If not… well that takes it down another path.


#3

I’m having an identical problem. I’ll check on the runtime question in a few hours time.

Mine is also a 2.7, running a slightly newer version of 3.0.2 (troubleshooting an IMU 2.0 issue).


#4

So I went through the motions, and the Arduino is in fact resetting.


#5

@Paul_S, are you using an IMU2 with your unit?


#6

Yes I am, and it has not been functioning.


#7

Got it. If you get a chance, try the 30.0.3 pre-release we have up. Should fix the IMU issues and that is most likely what has been causing the ESCs/Arduino to reset.


#8

Will do, I’ll report back on Monday!