Connectivity Issue


#1

We are oh so close to getting wet. I am having connectivity issues however. Difficulty getting openCockpit to open and when I finally do it drops out within a few seconds. All LEDs on top side adapter ON most of the time, occasionally middle LED Homeplug connect blinking. Control board seems to be working fine with BB blinking as expected as well. Even when I loose connection the control board still seems to be working and camera still sends signal but nothing else works. When I do get a connection and then proceed into diagnostic and hit calibrate compass the connection is immediately lost (coincidence??).

A few days ago this wasn't an issue and I made it thru the calibration of the ESCs fairly well. The thruster did not calibrate correctly. It continually runs at slow speed anytime I try to run the other two motors. I have to go into diagnostic and move the slider slightly to stop it. I will retry calibration of this but have to have a stable connection first.

Any ideas??

thanks,

Jim M.


#2

Hi Jim

Start by eliminating the Home Plug Adapter as an issue and connect laptop directly to BBB using patch cable. But you mentioned that you still get video so it has to be working ok in order for the video to reach the cockpit. The video comes directly from the BBB and does not use the Control card so it sounds like your issues are at the control board level.

Make sure you have good Battery voltage +12v to the control board.

If you are not using the latest image I would burn that to an SD card and give it a try.

https://github.com/OpenROV/openrov-software/releases

Dbl check the ESC programming.

Calibrate the esc's from the cockpit.


#3

I’m having this same issue and don’t know what to do. I’m using the TrustFire batteries in the 2.7 version; and it worked great first time, but now the cockpit won’t open!


#4

Grace, can you list the symptoms? The initial report that you are referencing is a bit confusing. Does cockpit come up and then stop sending telemetry and video? Just stop sending telemetry?


#5

Thanks for your response. The cockpit does not open; Chrome says it can’t connect to that page.

The LEDs on the ROV flash. The three lights on the land box are on (although the middle homeport light blinks sporadically). I tried resetting the Tenda connectors. But I also pushed the reset on the BBB on accident. I’m going to try loading a microSD card with the software and reloading. Unless you’ve other ideas.


#6

Let me know how this works out.


#7

Thanks yes I did see this. There are no blue lights (and I’ve restarted several times), so I am reloading the software image on the ROV now. Will say how it goes.