Connection Problem on New Build


#1

We are just completing the build of SN: 513.

Problems:

A. intermittent connectivity from home plug (connected/disconnected cycle every 10s)

B. unable to upload arduino firmware

Question:

Q. The instructions do not seem to clearly indicate which tether wire goes to which terminal of the home plug surface module. Which pin goes to the 5V of the USB REG Tether A or Tether B?

Direct Ethernet Connection to Beablebone / Unable to Upload Arduino.

I'v tried directly connecting the Beablebone to my computer via ethernet, bypassing the home plug adaptors. This results in a stable connection. However I am unable to load the latest 5.05 arduino firmware. I downloaded the .zip file from get hub. When I try to upload it the error says that it cannot connect to the Arduino, yes the beagle bone is connected to the Arduino based board.

Any ideas?


#2

Hi-

For the topside adapter, it doesn't matter which tether wire gets the 5V supply and which gets ground- the DC voltage over the tether is used to turn ROV power on and off, and the circuitry on the ROV can sense either polarity. As to the Homeplug adapters, I think I would first try resetting them both (see the instructions that came in the package), as a number of other people have written on the forum that this helped them.

For the Arduino software, can you copy and paste the actual error message you're getting? There used to be a common issue with setting up the Arduino Aconfig.h file, but when I look in the code in release 2.5-05 there seems to have been some changes made there, so I don't know whether that can be a culprit any more.

-W


#3

Hi Walt,

I tried racing the user guide and resetting the home plug adapters and found something interesting.

The surface home plug is behaving oddly in that the power LED is blinking quickly once every 3 seconds. The the Lan light comes on in a long pulse for two seconds and the LAN only comes on at a longer period.

In contrast the home plug in the ROV (power: solid always on, PLC blinks every 3s, LAN always on).

2. It turns out I was using an old image. I downloaded the 2.0.5 beta and was able to get things working, however the IMU is not recognized.

-E


#4

SOLVED! I had a solder bridge on the USB REG board between 3.3V and Ground. Fixed it....

Bad news looks like I fried the home plug board. The middle PLC light blinks and the power and lan are both off, and it won't reset to factory defaults.

Looks like I'll have to get a new one and solder it up.

Thanks for your help Walt!


#5

If you're using the 2.5.0-Beta2 software, the IMU is not turned on by default. Look in the Arduino AConfig.h file, and change the entry for "Has_MPU9150" to 1, and change the entry for "Has_5803_14BA" to 1. Then reload the Arduino software. This will enable the IMU and the depth sensor.

I don't know if they are turned on by default in the Beta-3 software.

-W


#6

Hi Walt,

Good point and thank you for indicating that. I tried adding that to the dozuki last night but it errored out on me every time I clicked save. My problem ended up being a a wiring issue I had swapped the SDA for 3V. It's great to see almost everything working now.


#7

Reply to Self,

1. I was using an old disk image. The newer betas posted work fine.

-Eric


#8

i have the exact same problem, the connection is intermittent, but not on a regulat intervall.

i have tried resetting both homeboards with no luck.