Connection Mystery


#1

Hey so I have had my ROV working well for about a week and I have been using it regularly. Recently after powering it off then powering it back on the camera stopped loading and now I cant even connect to it through chrome. I checked and my router hasn't changed anything and the settings for the IP address are still the same. When I pull up the "ping" in the command window it doesnt get a reply. Although, when I reboot it, it will hit 3 times then time out after that. The 2 of the 3 lights (outer lights) are lit on the top end adapter, the middle one is not working. The lights on the ethernet jumper on the beagle bone are on (orange and green) but they are not flashing.

What has happened here? does anyone know what it could be?

Thanks,

Cannon

(I realize that "mystery" in the title sounds way cooler than the problem that's actually at hand)


#2

Does the pink patch mean there was a short there and that the BBB is ruined?



#3

If you are using the Data Link Adapters, remove that connection and try connecting your Ethernet cable directly to the BBB and your laptop. that is step one.


#4

I disconnected the jumper and removed the BBB as a whole and have it powered by the 5V input. What's interesting, is when the BBB is remeoved the data links seem to talk to eachother with no problem over the tether.

Anyways, now I'm not sure how to access it. I am naive with the stuff. I cant figure out how to access it through my network settings on my lap top (its plugged directly into the back)

I know the software is installed and fuctioning because i retested it via USB with just the BBB. so how to I access it via ethernet cable?


#5

A few things to be aware of.

1. if you try to run the Control board and BBB make sure your power source can provide enough current. This may be part of your issue.

2. On the laptop or Desktop select your network adapter settings and change IPV4 settings to be a static IP Address of 192.168.254.2 SubNet Mask 255.255.255.0

3. In your Chrome browser type in 192.168.254.1:8080 this should connect to your BBB if all is working ok.


#6

Hey awesome, it connected! So now I know that the BBB works independently and so does the software.

I tested the connections at the DB-25 connector and I am getting 11.9V.

What seems to happen when I boot everything together (BBB inserted onto Control 2.5 board) is that everything powers up and the data link adapters (DLA) seems to communicate to each other fine, until the BBB completely loads, then for some reason all of the lights on the bottom-end DLA go out except the one indicating a connection with the BBB. When this happens the top-end DLA's middle light turns off.

to test my theory that the BBB could be causing the DLAs to stop I booted everything with the BBB completely unplugged and it the DLA's continued to communicate without any apparent issue. Then I tried this with the jumper to the BBB plugged in and it seemed fine. On the third test I reconnected the BBB to the control board and received the same issue. This issue happens with separate BBB's. I don't have other data link adapters to try and rule those out, but I'll have some tomorrow

I was always taught that if something isn't working and it was working perfectly fine before, to figure out what changed between then and now. This whole issue started when I was testing the top end of the sub in my tank and I accidently ran out of battery power and the whole sub turned off then turned back on.


#7

Try removing the Datalink adapter from the control board or just remove the Lan Cable between the BBB and the MediaLink Adapter and plug your patch cable from the laptop into the BBB and you should be able to control everything from the cockpit. This just eliminates the MediaLink adapters.


#8

Hey This is a great solution, I was able to connect again with the DLA take off the control board and the BBB plugged directly into my laptop. IM able to open the cockpit but im not able to control anything or to view the camera.


When the BBB is powered independently the camera boots and I'm able to view it.

Could this be a control board issue?


#9

Make sure the power source you are using can provide enough current to power up the webcam and everything else. Having no video from the USB Camera can be cause by not enough power.


#10

First of all, Thank you very much for your help and taking time to help me trouble shoot this. I am new to this so its nice to have a helping hand.

my power supply is only 2.1 Amp's at the DB25 with 11.9V which I think is the cause of the camera failure(I plugged this in because my batteries has drained and I was tired of waiting for them to charge).

Would this low power also make it so the servos and motors fail to relay back?

Cannon.


#11

Hey so I finally got it to work. I switched back to batteries. Something interesting, the only way to get the camera to boot is to go in on the diagnostics button and click "zero depth" and "calibrate compass" once I do that the camera kicks on. Then I have to wait about 30 seconds before any servos or motors will respond.

Im trying to re-upload the arduino firmware now, it seems to be getting stuck. but at least progress is being made.

Thanks


#12

I am experiencing the same issue as Cannon with the ROV booting up with no camera signal, ( but full control of all motors, servos and lights, and then if i press calibrate compass and zero depth i too get camera. However, After that point I never regain control of my thrusters, lights, or servo, they are off completely.

any help would be appreciated!

Nathan


#13

Hey Im still here with you on this. Now I am getting different errors every time I try to upload the Arduino Firmware. It seems to just stop at random places in the upload like it times out or something. I'm not really sure whats going on and since I am not well versed in this code I dont know exactly whats happening. It's very confusing.


#14

Finally got the firmware to upload again.... and im facing the same issue as before. But now I am with you and I never gain control of the thrusters or any other control other than camera feed.

Let me know if you make any progress!

Cannon


#15

Hey have you been able to figure out whats causing this or have you made any progress. I'm still stuck.


#16

All i have figured out is that if i turn on the LED's before i do the calibrate zero depth thing then after 30 seconds or so i regain control of everything, other than that i Have no further support:/ I'm really not a programmer, and dont have the time to learn how to read/write the ROV code and troubleshoot it or anything, im hoping now that someone else / someone from California HQ can help us out!

If you come up with anything please let me know!

Nathan


#17

I just uploaded a new SD card with onto a new BBB with datalink adapters.... so that was fun. It works--ish. It now will only stream the camera or control the motors. The only difference is that I dont have to hit the zero button. I think the page updating toggles between if I am trying to control it or if it's streaming video. Weird.

I would love some input from someone with programming knowledge on this. It's beyond at this point.

Cannon


#18

Hey Guys, I eventually got this to work. I pretty much just reinstalled the software and everything like 4 times and it finally "took". Now it seems to be working without issue. Still remains a mystery to me.


#19

Did you just have to re upload the firmware? or keep formatting the SD Card and re uploading the Firmware that way?


#20

I also managed to get Mine to work, as soon as I booted using the batteries instead of the power supply everything booted no problem!

i think i may have been having issues with the bench power box.

Nathan