Connection lost after first start up


#1

First start up had a still picture with 999+ latency. Attempted to DL firmware, but pressing button had no effect. According to directions, I cancelled after several minutes of no firmware download activity. Then connection to ROV timed out and now we are unable to reestablish a connection. I have tried pinging 192.168.254.2 through the terminal, but no response. ROV power ups and no obvious hardware problems.

Using OpenROV kit 2.6, tried on both mac and pc.

Help!


#2

Do you get the lights for the homeplug adapter etc on the control board? [LED6/TPWR, LED7/HP, LED8/ETH]

Also not sure if that was a typo but the ROV should be 192.168.254.1.


#3

Yes to the lights and we tried both 192.168.254.1 and 192.168.254.2

Jim


#4

If I understand the post, you had cockpit up and running at least for a moment. But now you cannot connect to the system at all. Correct?

My quick troubleshooting guide:

1) Isolate out the homeplug adapter (connect your cat-5 cable from your laptop directly to the beaglebone)

If you can connect directly to the beaglebone and things are fine, and it is just an issue with connecting via the homeplug adapter and all of the lights on the adapter are up and running I would double check power as I have seen similar symptoms as a result of low batteries or low amp desk power supplies.

If you cannot connect to the beaglebone even when bypassing the homeplug, double check the lights on ethernet adapter itself are both on. Also check to see if you are getting a pulse on the blue led #1 on the beagle which is supposed to be a 1 second heart beat. Ultimately in my experience this path leads to reformatting and re-imaging as SD card and doing a clean boot from there.

-Brian


#5

OK I have connected directly to the beaglebone and have blue pulsing lights and green lights at the plug. I am running the usb through the adapter. The 2.6 diections say to use 192.168.254.2 in that there is no sim card on this version. I tried both 192.168.254.1 and .2 and it says Oops! Google Chrome could not connect... I also confirmed all three lights come up on the adapter when pluged in.


#6

Hey Jim,

I am assuming that your handling your local IP address on your laptop to be on the same subnet since you mentioned you had it working in the past.

I will work on some other video's to show how the lights should be behaving in case we can use them to better isolate the issue. In the meantime, and I cannot swear this won't be a waste of time, if you have a space sim card around, I would go ahead and download the BETA image from the release directory on github, burn it to the SD card, and install it in the Beagle. The beaglebone should boot on the SD card if present. (note, it expands the first time it boots on an SD card and may require a reboot after about 15 minutes to get it finally come up on the SD card).


#7

Thank you, we were thinking about getting a sim card to try a mirror download. I think that is what it is called. I did set up my computer each time to confirm all settings were as directed. I can tell you that the blue light is not at a 1 sec pulse but more of a flicker if that helps.


#8

OK I have an update, we got a micro sd loaded with the beta. Started with the sd in the beagle and now after about 60 secs the center connection light goes out and the lights on both boards go out. I tried a couple of times both with the sd in and out no change. Could we have a bad board?


#9

Hi Jim

Start with Basic troubleshooting.

1.start with just the BBB only. Power it up using a usb power adapter from a cell phone or other device. Connect a lan patch cable from it to your computer. Set the IP address on your computer ipv4 to192.168.254.2 subnet mask 255.255.255.0

you should be able to use putty to SSH connect to the BBB using 192.168.254.1You should also be able to use google chrome and see the cockpit browsing to 192.168.254.1:8080

the power adapter may not have enough power to power up a web cam so you can test this in step 2.

if this works then.

2. Mount the BBB on to the control board. install jumpers on J12 to manually power up the Controller Card and BBB using your ROV Batteries. Connect your Lan patch cable from the BBB to your Computer again then power up.

You should still be able to connect to the BBB using Putty SSH and login.

If your web cam is plugged in you should be able to open Google chrome and connect to 192.168.254.1:8080 and see it in the cockpit.

You should now be able to update the Arduino Code from the cockpit.

If this works move on

3. Install jumper J17 on the control board.

Assuming that you have manually programed the ESC's

you should now be able to Calibrate them one at a time. Switch all esc's to off except the one you wish to Calibrate, once calibrated turn it off and move on to the next one. once finished then you should be able to turn them all on and control the motors.

4. If all is working then you can test the Home plug adapter. Install the Home Plug Adapter onto the Control Board and connect it to the BBB. connect up your tether and connect up your computer . All the led's on the Home Plug Adapter should light up and you should be able to connect to the cockpit. At this point you still have the jumpers installed on the control board to power it up rather than using the power through the tether to do it.

If you can't connect to the bbb using putty or Google Chrome then you may have to pair up the Home Plug adapters or you may have a bad adapter

try some of these steps and let us know how far you get.


#10

Ok let's start with power, you want me to plug into the usb on the BBB to a cell charger? I have gone through several and can not seem to find a compatable plug for that. The usb cables I have use two different ends. Also I am not familiar with"putty" ?


#11

There are 2 usb ports on the BB 1 for the web cam and the other small usb can be used to power up the BB. you could use the cable that is used to power the top side adapter and pug it directly to the BBB that should also work. Just Google Putty.exe to learn how to use it but it is very basic. once open select ssh and enter the IP address of the BB 192.168.254.1 make sure your laptop is set to192.168.254.2

once you know that you can talk to the BB then try Google chrome to see if it opens the Cockpit. if that works try plugging in the usb camera but keep in mind that the power supplied by the USB connection may not be enough to power up the camera properly.


#12

Thank you.


#13

Ok I had some time today to try this again. I got the BBB to power up and got the Cockpit to come up on my computer, I used Mozililla after putty changed the SSH, no camera. I found J 12 on the controler board but am unsure as to where I jumper to on the BBB?


#14

I assume that you are using Google Chrome browser?

There are two pins on J12 just jumper them together. Also J17 has two pins jumper those together.\

Also if you just have the BBB and camera powered up you should see video in the cockpit unless the power source you are using does not have enough current to power up the camera.


#15

I would like to schedule a time when I could talk to someone for about 15 minutes to get our rov online. I have tried the suggestions and it will not connect to the website. I have power I have lights I have no cockpit or camera and can not download the software. please feel free to email me at jzeigler44@comcast.net with suggested times when we could speak to solve this. My only other thought is to send it back to you for repair but then we learn nothing about what we did or did not do.

Jim


#16

I am in ADT time zone and can spend a bit of time with you and can be available. Before we do I would ask that you download the latest image to a windows system and burn it to an SD card.

https://github.com/OpenROV/openrov-software/releases/tag/v2.5.0-rc2

OpenROV-2.5-24.img.7z: Burn to a SD card and runs from the SD card

Remove the BBB from the control board and insert the sd card.

connect a patch cable from the BBB to your system LAN interface.

use a USB cell phone adapter and power up the BBB.

change the IP address on your laptop to 192.168.254.2 subnet 255.255.255.0

use google chrome and connect to 192.168.254.1:8080

please let me know if the cockpit comes up without the USB Camera connected.


#17

Ok I am in EDT timezone. I see five files for downloading, do I load all five on the sd or just the zip? We have the 2.6 kit and we did download a beta verision before but maybe we missed something.

Jim


#18

Sorry You spec'd it I missed it.


#19

OK I bought a new micro sd and loaded OpenROV-2.5-24.img.7z and put it in the BBB. I rechecked the IP to confirm the settings. I used Crome to connect to 192.168.254:8080 and it says This webpage is not available. I have a fast blinking blue light and a pulse like blue light on the BBB along with 2 green lights on the LAN connector.

Jim


#20

The IP should be 192.168.254.1:8080

can you confirm if your above notes were a type o

you should also be able browse to 192.168.254.1 as well and see a page showing three options for starting the Browser, Cloud 9 and another that will allow you to open windows explorer to gain access to the OpenROV Files.