Compass view on an iPad


#1

Hi OpenROVers

I have an OpenROV 2.7 and I’ve set it up to use with an iPad plus a Logitech bluetooth keyboard I already had (I haven’t attempted using a gamepad), and I’ve got everything working by adding and taking away a few of the buttons in the touchcontroller.js file (rather primitively as I’ve never tackled javascript before), the only thing I can’t see on screen is the compass (see below):

If I have chrome on a mobile site I can see the compass towards the bottom of the screen, but I can’t see any of the telemetry on the right or the normal items at the bottom. When requesting the desktop site in Chrome everything else comes back but the compass drops off, so I think it may just be hidden from view behind the footer panel. Is there any way to reposition the compass on the screen in Cloud 9 so it sits just below the video panel?

Very many thanks

Gareth


#2

I’m not sure how to fix this issue; but there will be new UI’s for tablets in the next software release that will resolve this. The touchscreen plugin in the current software hasn’t been maintained or updated for a while, and is not fully operational. It’s impressive you could get most of it working.


#3

Hi

I was able to work around the issue by installing the simple theme plug-in mentioned in an earlier discussion. So I now have a full screen video and all the functions on view which is ideal.

I look forward to the next software update.

Many thanks

Gareth


#4

That is excellent. I use the simple theme too, tho I haven’t tried it on tablet yet. I’m glad you got it going.


#5

Which portable router are you using?
how did you add the buttons on the cockpit?


#6

Hi Bruno

I’m using the TP-LINK TL-WR802N Wireless 300 Mps travel router, and I added
the buttons by editing the touch control file in cloud9.

Essentially I used the thruster commands in the touch pad part of the
script which didn’t work and used them to update the functions of the
existing buttons in the same file which did (while adding extra buttons
where necessary by copying and pasting the script of the existing buttons)
and amended the x and y orientation so that they were is the most
convenient place on the screen. I then deleted the touchpad script from the
file. So I didn’t fill the screen I also deleted all other button functions
(instead using a splashproof Bluetooth keyboard for lights, lasers, etc.)

I’d never meddled with computer script before but the commands are pretty
self explanatory so it doesn’t take too long to work out what needs
amending. I need to fire up my OpenROV to remind myself exactly where what
I did, but I should be able to send you a copy of the script I when I do.

Cheers

G

Ps. Before amending anything I made sure I copied the original touchpad
file to another location within cloud9 so if it all went horribly wrong I
could still reinstate everything as it was.


#7

Pps. Although I believe the new beta firmware may have solved the touch control issue so that could be worth trying also.