Communication to rov from computer


#1

Hi All,

still strughling with issues with the ROV. The latest one I have now is that after having been able to run it from the computer for the last month or two (in air, not in the water) I can now no longer access it at all, ie it appears that I can no longer talk to the rov. I've set the ip to static for the computer (192.168.254.2) and the IP address I'm using in google chrome is 192.168.254.1

I've tried pinging the address from my computer with no joy. The whole system WAS working but just the other day ti died.

Interestingly when I power up the rov and then plug in the topside adapter to the computer I get both the green and yellow lights on the lan plug on the rov lighting up but if I plug in the top side adapter and then power up the rov I only get the green light. Top side adpater seems to be working ok, lights are flicking on etc as they have in the past

anyone got any ideas?

thanks

JAmie


#2

further to this, I've just disconnected the home plug adapters and run a lan line straight from the computer to the board, same issues

thansk

Jamie


#3

Remove the BBB from the control board and power it up with a small usb power adapter.

plug in a patch cable from the BBB to your laptop.

Set the Laptop IP to 192.168.254.2 subnet 255.255.255.0

See if you can browse to 192.168.254.1:8080 in Chrome. if not try a ping to 192.168.254.1

if no ping make sure your Laptop Lan Adapter is Active and working.

if that is ok then try loading a new image to the SD Card and boot from it.


#4

Hi Daivd

sorry for the slow reply, been out at sea.

Tried that, no joy. I'm confused. I thought that version 2.6 had the software on the BB

Jamie


#5

There should be a small SD card that came with the kit, this will have the system installed on it. If you do not have this you can pick one up locally and burn the image to it. Then instert it into the BBB and then try connecting to it from your laptop.


#6

The 2.6 kits shipped with software installed in the eeprom on the beagle bone black. Anyone with a 2.6 kit who upgrades software should start with buying and burning a SD card to test the new software. You can always go back to the prior software by pulling out the SD card.

+1 David's recommendation to burn the latest code to a SD card and try that. It is possible, rare but possible, to corrupt the flash memory holding the image. If so, re-imaging the flash eeprom is simple enough. The SD card method helps isolate this as the cause to the loss of connectivity.

-B


#7

Hi Brian, thanks mate. I've copied images etc to the flash card, no help. What I'm confused about is it 2.6 has the code in the eeprom, how does it know to go to the sd card to get a new image? or does it check there first by default?

at any rate, copying a new image over did not fix the issue, I still can not ping the BBB

thanks

Jamie


#8

Hi Brian

Do I read you correct that we should leave in the SD card when upgrading to latest image

Dave


#9

https://github.com/OpenROV/openrov-software/releases

There are two images one to load the BBB Flash with the image and the other is used to run the BBB from the SD card. If you want to test new code you can load the image that will run from the SD Card so when it is inserted into the BBB it will have a higher priority over the copy that is in flash. If you want to burn the latest image to Flash then load the SD card with the image that will copy to flash then when you insert it into the BBB and power up it will automatically copy to flash. Then remove the SD card and reboot.


#10

It uses the SD card image first by default.

When the BBB boots up you should see some LED activity.

check the pins in the RJ45 connector on the BBB to make sure they are not bent or damaged same for your laptop.

Make sure you are using a good patch cable, maybe try another one.

Can you connect to your home network using the lan & patch cable connection.

You could also try plugging the BBB into your home network and it will try to pickup a IP address via DHCP, then use AngryIP Scanner to find out the IP address it was assigned.


#11

Hi Daivd,

tried all of this, zero success. Getting seriously frustrated :-)

Jamie


#12

Well that is a bummer. Dom just submitted code that actually cycles the ROV lights when it boots so that you know the image is running. That might help isolate the issue in this case, but it will be a few days before that is in a downloadable image.

-Brian


#13

I got the same problem with low voltage at the batteries. Have you checked the batteries?

Henning


#14

Hi Jamie

The image that is used to copy from the SD card to flash will cycle the led's on the BBB when it is complete.This is described by Brian in his instructions on how to install the flash copy. Does this happen when you try to copy the image to flash? This may give us some clue to see if the BBB is functional.


#15

Hi David,

unfortunately, no, the leds don't cycle.

thanks

JAmie


#16

Sounds like you may have a bad BBB,if this came to you in the kit from OpenROV then check with David to see what he can do for you.