Communication problems with the openROV 2.8


#1

Hi

I.m trying to get my OpenROV readdy to use, but run into a problem today.

When I start up with freshly charged bateries, plug in USB power and ethernet to the topside homeplug , the ROV boots up as it should. but then the comunication case begins.

I have checked the computer IPv4 settings against the manual several times and its correct, the etehenret has electrical connection to to topside box. the LED lights up as i should.

But there are no change in reach it with a ping or a http request on port 8080.

How can I verify that the beaglebone black actually boots correctly ? is it possible to attach an monitor to it or any way to se it’s booting up ?

how can I veriy that the homeplug ethernet actually can transfer any ethernet traffic to an other computer ?


#2

Welcome to OpenROV!

Did you go through the entire process of flashing the latest image onto your Beagle? See this thread about how to install etc.


#3

Hi

I managed to boot it up once from the SD card, and itworked. When I
restartet it,it would not boot up again either from memory or SD card
There should be an status LCD on the ROV it’self so it would be possible
to se what is not working and that boot is ok.

I just shecked that the SD card i OK, and it is.


#4

I solved this by upgrading to latest image


#5

Well done! Sorry if my advice was a bit misleading. I wanted to emphasize that you should apply the latest image! I am glad it works now!


#6

Thank you @Fe3C for helping @jneegard get this problem figured out. It is so wonderful to see community members helping each other out like this!


#7

It’s onlly one smmall case left, from the latest image I got a compiling
failure when trying to update the android part. But it works well enough
for testing it in a freshawater tank.


#8

What version of the software image are you having the failure with?


#9

30.0.3 FLASH version


#10

Can you upload the error codes you are getting?


#11

Hi

This is det messages I collectet:

undefinedstaging: build dir is /tmp/tmp.eAWJRwCeg7
staged src in to build folder
staging plugins
mv: cannot stat ‘/tmp/tmp.eAWJRwCeg7/src/Device.cpp’: No such file or
directory
sed: can’t read /tmp/tmp.eAWJRwCeg7/src/Device.cpp.template: No such file
or directory
rm: cannot remove ‘/tmp/tmp.eAWJRwCeg7/src/Device.cpp.template’: No such
file or directory
Searching for Board description file (boards.txt) …
/usr/share/arduino/hardware/arduino/boards.txt
Traceback (most recent call last):
File “/usr/local/bin/ino”, line 6, in
main()
File “/usr/local/lib/python2.7/dist-packages/ino/runner.py”, line 64, in
main
e.process_args(args)
File “/usr/local/lib/python2.7/dist-packages/ino/environment.py”, line
317, in process_args
all_models = self.board_models()
File “/usr/local/lib/python2.7/dist-packages/ino/environment.py”, line
261, in board_models
self[‘board_models’][multikey[0]][’_coredir’] =
os.path.dirname(boards_txt)
TypeError: ‘str’ object does not support item assignment
firmware-build.sh: : Compile of the Arduino image failed.
firmware-installfromsource.sh: Building Firmware Failed! Aborting


#12

After you flashed the BBB did you remove the SD card from the ROV?


#13

I have tried both with the card in the ROV and with the card taken out of it


#14

Can you try uploading the firmware through the command line.

To do this you will need to use SSH. We have a built in SSH terminal in the software version 30.0.3.

If you go to port 3009 (either openrov.local:3009 or 192.168.254.1:3009 in Google Chrome) you will open the terminal.

openrov login: rov
password: OpenROV

Once you have an SSH connection run the following command line.

sudo /opt/openrov/cockpit/linux/arduino/firmware-installfromsource.sh

It takes a couple of minutes to complete.

It should end with

upload successful!
uploaded firmware

Let me know how this goes. If it fails an upload of the log file just like you did above would be helpful.