Communication problems using Homeplug Adapters


#1

I´m testing the communication between the computer and the ROV, I connected the usb cable from the TOP SIDE BOX to the computer and I saw the power led turned on, then when I connected the ethernet cable the LAN led turns on, but the PLC led stays off.

I tested the home plug ethernet card of the rov disconnected from the controllerboard supplying 3.3V on the 3 pins connector, I connected the ethernet cable to the beaglebone (supplying it using the usb cable) and I connected a pair of cables from the 2 pins connector of the card (homplug adapter of the rov) to the terminals of the topside box.

When I connect the 3.3V I see the power led turns on. The problem is when I connect the ethernet cable I don't see the LAN led turns on, and the PLC led stays off.

What would be the problem with the homeplug adapter of the rov?, Am I doing bad connections?. I think the problem is related to the connections of the homeplug adapter of the rov.

I already do the test of connecting the beaglebone direct to the computer and and actually I can to see the cockpit and the image of the camera, so the beaglebone is ok, the problem is on tenda adapters.

Please, somebody can give me ideas. Attach two images of my connections.

669-homeplugadaptertopsidebox.bmp (1.37 MB) 670-homeplugadapterrovsside.bmp (1 MB)

#2

Hi Jorge

Not sure what cable you are using between the BBB and The Rov Homeplug Adapter but you can try a standard Lan patch cable to make sure you don't have any issues with the one you are using. You can also attach the ROV Homeplug to your Home router or switch rather than the BBB just to test connectivity through the Homeplugs to the internet from your laptop.

Regards

Dave


#3

I've already tried the test that you suggested, I used a standard Lan patch cable instead of the small extension cable tha came with the rov, however the LAN led didn't turn on. So I suppose that the patch cable is not the problem.

Another idea?

Said


#4

Hi Jorge

Check the Homeplug Ethernet connector pins to make sure they are ok.

Here is a link to a Medialink Utility that I have not used but may have something in it that may help. http://www.medialinkproducts.com/support.php

Also you can use a soldier Iron and redo the pins on the PCB in case you have a bad connection.

other than that you may have a bad adapter.

I had purchased two sets of these and in testing I found that they worked together with no issue but I thought that they were paired but it looks like that is not the case.

Also did you try connecting it to your home network to see if it established a connection.


#5

Hi Jorge:

If you have checked the wiring multiple times and can't find a problem, one last thing to try is to reset both of your adapters to the factory configuration by pressing and holding the reset button on the adapter. See the instructions that came in the adapter box for more details.

For unknown reasons, occasionally we have builders whose Homeplug units don't pair properly, even though the adapters are good and the wiring is good. Resetting the adapters takes care of the problem.

-W


#6

Hi David

I finally solved the problem, I don't know exactly what happened but I supplied the homeplug of the rov's side with the power regulation board that comes with the adapter solding some cables to the pins and the power led turned on and when I connected the beaglebone the LAN led turned on !!!! finally, but the middle led (PLC) still stayed off. Then I applied reset to both adapters and they started to communicate!!!. Next, I did the test that you suggested connecting one adapter to my router and the other adapter to my computer and I obtained internet connectivity in my computer, then I tested with the rov and I could see the cockpit, jeje. I guess the problem were that I wasn't supplying enough current or something like that.

I was using a power supply of 12V 1A and a voltage regulator of 3.3V to supply the ethernet board, but I saw that the regulator overheated. Then I supplied it with the power regulation board and I measured the current in the ethernet board working and I see that it consumes 1A. Possibly the current of my regulator was in the limit current can it supply, so I think needed more current.

Thanks for your help David

Said


#7

Hi Walt

Thanks for your help in fact I applied reset to both adapters and then they become paired and started to send data.