Comms Problem between HomePlug adapters


#1

Hi,

I got my OpenROV v2.6 a couple of months ago, and I have it all built.
I'm now starting to test that it's actually waterproof.


Yesterday, everything was connecting fine and I was able to connect to cockpit and run motors.
I removed everything from the electronics tube and put the ROV in a bath tub.
The good news was that no water got in.


Today, I've put everything back into the electronics tube, but now the Homeplugs won't communicate.


I've been reading as many posts as I can about troubleshooting these comms issues, but still can't get it to work.
On the topside adapter, the Power and Ethernet lights are on, but the Homeplug light isn't
On the ROV Board, the TPWR LED6 is Green, HP LED7 is off, ETH LED8 is Orange and PWR LED1 is Green


I've connected the BBB directly to my laptop via Ethernet cable and plugged power directly into it.
I can then connect to 192.168.254.1 without any problems and view the cockpit.

I've installed the Medialink Powerline Utility software and can connect to the Homeplug in the Topside adapter without any problems, but the ROV HomePlug adapter does not appear
I've then swapped the HomePlugs around (i.e. Topside adapter plugged into ROV and vice versa)
When I run the MediaLink software this time, it again connects to the Topside adapter only (i.e. the one that was previously in the ROV)

This suggests to me that both Powerline Adapters are working, but aren't communicating.
I've reset both adapters to factory settings in the software, but to no avail.
I've also tried using their reset buttons, again with no effect.

Does the TPWR LED6 light on the ROV relate to power to the HomePlug?
(If I unplug the ROV HomePlug, that doesn't light up and more, so I assume that's what it is)

I assume that the ETH LED8 light relates to network connectivity between BBB and HomePlug. Is that correct?
I'm currently using the supplied ethernet cable to connect the BBB and HP, but I've tested it in the laptop and it appears to work fine.

My final test was to check the power level of the ROV batteries.
With the BBB plugged into the main board, I've connected the ethernet cable to my laptop and powered it up.
When I connect to the Cockpit this way, it shows 11volts.

Should that be enough to power everything?

If you have any ideas how to get these Homeplugs to connect I'll be extremely grateful

Thank you
Steve


#2

Hi Steve

11V power is ok to run everything. even down to 9.5V or so is ok.

Try a new patch cable between the BBB and the Control Board.

Check your tether connections on the BD25 connector to make sure there are no shorts between the pins. Maybe use an ohm meter to test continuity from the DB25 to the Topside HomePlug adapter on each wire to make sure the cable is not broken.

The Homeplug adapter requires 3.3V from the control board to run it. I know that there are led's on the control board to show the status of the Homeplug adapter but I don't know what they are without doing some digging around. If I find them I will post them here for you.


#3

Hi David,

Thanks for the prompt reply.
I've just tried a new patch cable (which I tested first)
Unfortunately, it's made no difference.


The Homeplug lights on both the ROV and the Topside are not lit, and there's no network connectivity.

I'm going to do some more research, but if you (or anyone) come up with anything I'll gladly give it a go.

Thanks

Steve


#4

Make sure you test the tether cable with an ohm meter for continuity.

You can also try a short piece of Twisted Pair wire to go from the topside Homeplug to the ROV.


#5

OK, it looks like I have some progress here.

It definitely looks like a 'simple' pairing issue with the homeplugs.

I've currently got the ROV powered up with the Homeplug connected to it and drawing power from the ROV batteries.
The Homeplug is connected to a network switch

The Homeplug in the topside adapter is connected to the same network switch, as is my laptop.

Using the Medialink powerline utility software, I can sometimes see both adapters, at other times, plugging the 2nd one in will disconnect the first.

After resetting the adapters a number of times, and then resetting the network name of them they finally paired.

How long this will last is anyone's guess.

I might see if there is updated firmeware for these adapters that may make them a bit more stable.

However, it seems to prove that everything important in the ROV is fine, and it's just a homeplug pairing issue.

Thanks for your help David.

Have a good evening

Steve


#6

Steve,

I've had this problem before where the topside adapter would sometime lose communication and wouldn't turn anything on. For me, it was a hardware issue where once I put the case on and plugged everything together, the 2.6 topside adapter board and Homeplug board would disconnect slightly. This is why you would see the "Power" and "Ethernet Connect" lights on, but not the "Homeplug connect". My solution to make sure they didn't separate was to simply wrap electrical tape around both ends to hold them securely together.

See if that works or not.

Kevin


#7

Hi Kevin,

Thank you very much.
I'll check all the connections out again tonight.


After successfully pairing the home plugs, I put them back into the ROV and connected via the BBB.
It all stopped working again.

I'll check the connections again and hope that highlights a problem.

Thank you

Steve


#8

OK, it looks like the problem isn't with the Homeplug adapters afterall :(
I've bought some replacement Tenda P200 adapters, and swapped the old ones out.
Unfortunately, they're still not pairing.

I have 2 lights on the topside adapter - Power and Ethernet
Lots of lights on the ROV too, but not the Homeplug light.

I've tested continuity of the tether, between the Topside adapter, and the soldered connections on the DB25. That looks fine, and it's also powering up the ROV so the tether is presumably fine.

There's 4.6volts at the Homeplug Adapter on the ROV and the Topside Adapter

Is there anything else I can easily check?

Thank you for the help


#9

I'm trying to strip this down as much as possible to make it easier to troubleshoot the problem.

If i just had a bare controller board, with the DB25 and Homeplug adapters connected, should I expect to see the homeplug lights on the topside adapter and ROV when I power it on?

(i.e. no need for BBB to make a connection between the Homeplugs)

Thank you


#10

Hi Steve

No you would need the BBB with the lan connection to the Homeplug in order for it to work.

you can try the following setup.

remove the BBB from the Control Board.

plug a patch cable from your home network router to the Homeplug adapter on the control board. Connect your tether up to the ROV as you normally would and power up the ROV.

This should establish a connection via the Home Plugs from your Laptop to your home network using DHCP to get an IP Address from your home network. Make sure that DHCP is configured on the Lan Adapter of the Laptop. If you turn WiFi off on the laptop you should be able to get to the internet via the Lan Adapter through the Homeplug adapters to your home router. You should see the 3 led's lit on the Homeplug's if connectivity is established.

If you don't get connectivity on the HomePlugs then they may not be paired up.

With the BBB removed you will be able to see the LED's better on the Control Board Homeplug adapter.


#11

Hi,

I've just come back from a few days away and was hoping that with a fresh mind, I'd get this working and realise what I'm missing.

Unfortunately, that isn't the case

As per your suggestion, I've removed the BBB, and plugged a patch cable from the HomePlug adapter to my router.

My laptop is connected via network cable to the topside adapter, which is powered via the USB port of my laptop.

As before, the topside adapter board shows the Power and Ethernet lights only - no Homehub lights.
The Controller Board shows a TPWR light, and ETH light and a PWR light.
Still no HP light.
No surprise, but I don't get an address via DHCP.

These are new Homehub adapters that were tested as paired prior to dismantling and using on the ROV.

I've read in various places that the Homehub adapters need 3.3V.
Is it unusual that I'm measuring 4.6V across both adapters?

Thank you


#12

I should also say that a light on my router is on when I connect a patch cable from the HomePlug adapter on the ROV to the router.
That suggests to me that there is a network connection between the two.

Similarly, if I connect a patch cable between my laptop and the top side adapter, I see lights on the network jack on the laptop, which suggests that too is working.

Given that I've checked the continuity of the tether, the only thing left is the controller board itself.
Is there anything I can check on the controller board?
There must be some track from the DB25 tether pins to the homeplug pins on the controller board... If so, can it be checked for continuity?


#13

I've now discovered that the 4.6 volts that I was measuring on the ROV Homeplug board was across the data pins, rather than the power pins.
As such, I was getting the voltage from the topside adapter.


I measure the voltage of the power pins, and it was a bit below 3.3v
I've therefore been charging all of the batteries.

I was feeling confident... unfortunately, the HomePlug adapters still don't pair.
I'm now measuring 3.27v across the power pins

I have continuity between the 4 data pins on the top side HomePlug adapter and the 4 on the ROV HomePlug adapter.
I really can't think of any reason why they won't pair.
As soon as I remove them from the ROV and put them back in their original housings and plug them into my household sockets, they pair immediately.

Any further thoughts on what I can check?

Thank you

Steve


#14

Do you use home plug adapters at home at all? or do you live in a building where some one else might have one plugged in? It is very easy for them to 'find' another home plug, just enough to not connect to the one you want it to. It can connect through your laptop if it is plugged into the wall, or the network if you are connected through a LAN.

When mine don't connect, that it is often the reason. A computer at home uses one. And it goes offline sometimes when I am having troubles.

It is possible for them to have issues from RF waves as well. But they usually do work. :D


#15

Hi,

I may have got the solution to this. I'm planning to do some more testing tonight.

I think there were 3 issues.
Firstly, I think that there wasn't sufficient voltage being supplied to the ROV Homeplug adapter. The last time I measured it, it was definitely under 3.3v
In an attempt to troubleshoot this, I had also swapped the tether wires around in the topside adapter.
Finally, it sometimes takes a long while for the homeplugs to pair - anything up to 5 minutes.
I think that by the end I was getting a bit impatient.


After recharging the batteries, and connecting the tether both ways, it finally connected, however it took about 3 minutes.
On a second test after that, it took nearer 5 minutes for them to pair.

anyway, hopefully it was as simple as that.


#16

I just had a re-occurrence of this a few min ago. I restarted a number of times with no luck, then realised I had my topside adapter and tether spool right by my wireless router. I moved them a few feet away, restarted and it worked right away. I can't be certain that is the problem, but my recent issues increased quite a bit since I moved my router to the area I usually work on the rov. Has anyone else noticed a correlation?


#17

I just wanted to confirm that the connection of my Homeplugs has been pretty stable for a couple of days now.

Because I had 3 or 4 different issues affecting my connection it was very hard to troubleshoot.

Now that I know the connections are correct, it's just a case of patience, and waiting for the Homeplugs to connect


#18

Hi darcy,

It seems to be incredible, but I noticed the same thing. My coonection worked fine since the beginning but 2 days ago I moved my work desk close to my wireless router, and I started to have a very irregular connection.... I read the forum and tried almost everything (direct connection, reset adapters, voltage check.....) but still nothing. After reading your post I moved the rov and the pairing came back perfectly!!! I try to came back close to the router and I lost again the pairing....I noticed something else: as mentioned in the forum (Ilive in a building) there is probably any pairing systems in the power network; when my laptop is plug on the power supply I losecalso the pairing..... Interesting!!! Sorry for my English and thank you


#19

Hi i was wondering if this problem has been solved? Are you using AV500, with AR7400 chipset?

Anybody confirm that this ar7400chipset, can work with straight powerless cables, without 50hz mains.

Myself use 2x Sitecom LN-509, with 3x gigabit lan ports. Can't get it to work properly....

Similar problems, difficult connections and slow speeds up to max 10mbs, (reported by the config software) tried different firmwares. I used a 1m twisted pair in between, both powered by 3v3 suppies.

However when using them unmodded in the wallsocket, close toghether link is instant and 330Mbs is recorded.


#20

Hi,

I don’t know if my issue is properly fixed. The ROV is packed away for the winter
However, I did find that it was more of a problem on the bench than it was when I was actually using it.

Based on a few other people’s comments, I’ve come to the conclusion that the problem probably related to the course proximity of the ROV to my router and/or the fact that on the bench, my cable between ROV and adapter is quite tightly wound.

HTH

Steve