Cockpit Won't Open


#1

The first time I connected the ROV to the computer it worked great! Did the laser calibration and everything. Now, however, cockpit won’t open. When I got to http://92.168.254.1:8080 Chrome returns “This webpage is not available” And we need to bring the ROV with us for research next Tuesday! :confused: I don’t know why it stopped working. All the wiring looks fine. I’ve followed these troubleshooting steps from a previous forum discussion, but it still won’t connect.

  1. Are all three lights on the topside adapter
    NO; the middle LED (to homeplug) is on at first, but then turns off.

  2. If so, try pulling out the ethernet cable and pushing it back in making sure it get pushed in all the way.
    Did that.

  3. If still having problems, can you “ping 192.168.254.1” successfully?
    NO I get “request timeout… host is down”

3a. If not, have you validated that your laptop is still configured with a hardcoded 192.168.254.x address
Yes.

3b.If yes, can you ssh in to the ROV using a tool like putty?
How do I do that?

  1. I’ve also tried this: “1) Ensure that both wires on the tether are securely connected to the topside adapter. 2) Press and hold the reset/sync button on the topside adapter for 3 seconds, and then do the same to the one one in the ROV.” Didn’t seem to help.

  2. I also got a microSD card and imaged it with the 2.7 software, and plugged into the BBB but it didn’t seem to do anything different. There are no lights on the BBB (not that blue one that’s suppose to be there…) and the Ethernet port doesn’t light up either.

What do you think I should do from here?

Many thanks for your help!


#2

I’m not sure I imaged the microSD card correctly… Could someone run down how to do that? I don’t see a clear guide online.


#3

Are there any lights at all on the ROV itself? The ROV should always power on with at least two blue LED on the beaglebone and a bunch of amber LED activity on the controller board itself. If it worked before but no activity now, also ensure the ROV is running off charged batteries and that they have a firm connection in the battery tube.


#4

There are no blue lights; only the yellow and green on the openROV board. The LEDs by the webcam flash. I just charged the batteries before testing; but they are not the recommended batteries for v2.7. They are the TrustFire batteries that were recommended for earlier versions. (Could this be the issue?)


#5

No blue lights is a symptom of at least one problem. I am assuming the ROV still ships with the black USB to micro USB cable. Take the beaglebone off of the ROV and use the the cable to connect the beaglebone directly to your laptop. The beaglebone should power up with blue lights.

If it does, then unplug and reinsert on the controller board of the ROV. Given your time frame I will also make sure OpenROV support is aware of the thread in case they have other ideas.


#6

I just connected my laptop directly to the BeagleBone USB<->microUSB. It doesn’t power up (no lights turn on). When I press the “Power” button on the board a blue light will flash but then turns off. Think this means the board is bad?


#7

hmm. Yea, that sound like the Beaglebone is having a problem. I recommend reaching out to support directly https://docs.google.com/a/openrov.com/forms/d/1erC38nIh78S734N2UQK6Xx3VYgYXOvShA9TQ25Pyzs0/viewform?fbzx=329119282362925793. I’ve already sent this discussion to support, but mabey something can we worked out to overnight a new beaglebone.


#8

Excellent, thanks again. Waiting for response from support then.


#9

Hello Grace,

I am sorry to hear about your problem.

If the BBB is disconnected from the ROV and powered through USB and there are no lights that are turning on, this is a symptom of the board having issues.

The light that flashes when you hit the reset button, does it flash for a split second and then turn off?

-Brian G.


#10

Exactly. The light on the BBB flashes for a split second then turns off when I hit the reset button.


#11

Hello Grace,

This unfortunately does sound like the BBB is not working anymore. I am checking to see if anyone is in the office this weekend to see if we can get one sent out.

Was there anything you changed or did between the first power up and when it stopped working?

-Brian G.


#12

That would be excellent. The mailing address would be different; we can email. When I first tested the large connector wasn’t set in place with epoxy yet, and the batteries were fresh from the packaging. On the second test they were fully charged… Honestly I don’t think these things would’ve made a difference. I can’t think of other differences.