Cockpit wont load


#1

Hi All,

I have tried searching the forum with out any luck. My problem is that the cockpit wont load any more. Cloud 9 and Network share are working however the cockpit service doesn't. I can start the service however it stops after several seconds.

I have tried starting the cockpit manually through ssh. I get the following error message

/opt/openrov/node_modules/serialport/node_modules/bindings/bindings.js:91
throw err
^
Error: Could not locate the bindings file. Tried:
→ /opt/openrov/node_modules/serialport/build/serialport.node
→ /opt/openrov/node_modules/serialport/build/Debug/serialport.node
→ /opt/openrov/node_modules/serialport/build/Release/serialport.node
→ /opt/openrov/node_modules/serialport/out/Debug/serialport.node
→ /opt/openrov/node_modules/serialport/Debug/serialport.node
→ /opt/openrov/node_modules/serialport/out/Release/serialport.node
→ /opt/openrov/node_modules/serialport/Release/serialport.node
→ /opt/openrov/node_modules/serialport/build/default/serialport.node
→ /opt/openrov/node_modules/serialport/compiled/0.10.17/linux/arm/serialport.node
at bindings (/opt/openrov/node_modules/serialport/node_modules/bindings/bindings.js:88:9)
at Object.<anonymous> (/opt/openrov/node_modules/serialport/serialport.js:6:44)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object.<anonymous> (/opt/openrov/src/lib/Hardware.js:1:80)
at Module._compile (module.js:456:26)
cockpit.js has exited after 3 restarts

Does anyone know what could be causing this error message?

Thanks,

Peter


#2

Hm. Are you running with a SD card or from the eeprom (built in memory) on the bbb? I would guess a corruption issue on the image somehow. Reburning the SD card will probably fix it. If it is using the eeprom reloading it will probably fix it. I need to do a quick google to pull the command to check for disk corruption...


#3

Thanks for the quick reply Brian.

I am not using an sd card, so how would I go about reloading the eeprom?

Is it worth running it from an SD card instead?

Cheers


#4

in the /opt/openrov/linux/, there s a script copy-to-emmc.sh. run the script, it ll help to copy the whole OS to the build-in eeprom. im not sure if it s working reliably or not :) but it is definitely fine to working on sd card.

from the err log, u can see what the binding module has problem. u can go to the folder /opt/openrov/node_modules/serialport/node_modules/bindings and see what happen in the file bindings.js


#5

one more thing, i recommend u use terminal n go to the folder node_modules, type

"npm install". if having smt wrong, its error description ll give u more information. after updating to the latest software, I had a lot of problem to make serialport compile correctly. so good luck :)