Cockpit Software release 2.5RC2


#1

The latest bits have been wrapped up in to downloadable SD card images along with release notes and install instructions on github releases.

There are over 6 months of updates that have been pending... so this is a rather large drop. These bits will be the final "Stable release" bits as soon as we finish testing on the cape based ROVs. If you have a cape based ROV and want to help, please test and make sure firmware updates work, basic controls still work and that you let me know what you find out!

If you have been sitting on the sidelines a while, please note that we are not supporting the update.sh script that you can run by ssh'ing in to the beaglebone. We made substantial repository changes that likely broke that script. Instead we are asking everyone to pave the new image on to a new SD card.

I will be following up over the next few weeks with posts that explain a lot of the changes that have been made. For those that are testing, please note that you can mouse over the image of the keyboard and a list of keyboard commands will pop up.

Change list:

  • A new default dashboard allowing starting the Cloud9 IDE, File Sharing, and the Cockpit has been added on port 80 of the ROV
  • Support for the MS5803 depth sensor added
  • Support for the MPU9150 IMU sensor added
  • Data logger plugin added
  • Major refactor of logic to plugin architecture
  • Major performance improvements in the browser and video
  • Beta touchscreen controls added for touch enabled devices
  • System now automatically expands the image to take over all free space on the SD card on initial boot
  • Latency measurement controls added
  • Heads up display can now be toggled off
  • Changed the UI to add more space for telemetry
  • Beta tank control mode added
  • Added saltwater/freshwater toggle
  • Changed cockpit to a darker theme that works better at night
  • Added beta depth and heading hold
  • Added beta fly-by-wire
  • Lots of fixes to the compass in cockpit. Note: Currently orientation to magnetic north has been disabled.
  • Lots of fixes to the things that are interrupting camera video
  • Made default motor response more aggressive
  • Fixed onboard temperature reporting on the controllerboard
  • Added support for the OpenROV Controllerboard 2.x class of boards
  • Sensor board support in the Arduino code
  • Logging of telemetry data to persistent storage on the browser
  • Ability to download telemetry in json
  • HUD depth and thrust indicators
  • Laser keyboard toggle
  • Depth Zeroing button
  • Light on/off toggle key

#2

Great work Brian I appreciate all the work that goes into doing this.

I downloaded and burned the OpenROV-2.5-24.img to an 8GB sd card.

booted the ROV and the cockpit came up as expected.

Tried to upload the Arduino code a few times and it fails each time

Make failed with code 2

firmware-build.sh:: Compile of the Arduino image failed

firmware-installfromsource.sh Building Firmware Failed! Aborting

Once I rebooted the BBB and tried the Upload again it worked ok.

Rebooted an all seems to work yeah!!

I will try the Flash image next but I have a ?

Once the Flash has been burned and rebooted it will now run from flash.

My ? is will the ROV run off the sd card OpenROV-2.5-24.img if it is inserted into the BBB once the BBB has the flash copy installed.

If you wanted to remove the Flash copy is that doable?

I am thinking that if I had a problem and wanted to use my backup sd card would it work?


#3

Thanks for the info David. The issue with needing to reboot before applying the fix is already in the release notes, but clearly needs to be made bold or something!

Yes, the SD card takes priority over the emmc flash. You just have to remember to push the matching Arduino firmware when switching cockpit versions.

-Brian


#4

Hi All:

As Brian briefly mentioned in the release notes, this software drop has the magnetometer portion of the compass disabled by default- it works as a gyrocompass only.

If you have the ROV pointing north when you boot it up, the compass will read correctly. The gyro does have some drift, maybe 10-20 degrees/hour.

Brian and I are actively working on how to properly calibrate the magnetometer, and will have more to say about that in the coming weeks.

-W


#5

Hello Brian!

I have a Kickstarter Cape based ROV, installed the latest Image on the SD, everything ok there. Then I tried to update the arduino thrue cockpit, did not work, then I changed the settings in AConfig, then I was able to write the arduino code. But now when I reboot still no hardware control of motors, light etc. /Erik


#6

Brian,

Just letting you know I just upgraded to the 2.5 RC3 tonight and everything works perfectly. I'm using a Rev B BBB (my original OpenROV 2.6 came with the Rev A6A BBB), Google Chrome and a Logitech F310 gamepad.

I had to play with the software for a bit as the camera and gamepad originally didn't work, so I went into the Dashboard, stopped the Cockpit, restarted it in the Dashboard and everything worked.

I love all the new features and hooking up the IMU module is my next task!

Kevin