Challenge with the 2.6 controller board


#1

I have a challenge with my 2.6 controller board. Put all the electronics together yesterday. updating arduino went as planned.

I configured the ESC as planned but I was only able to perform calibration of one ESC (the one connected to D6). None of the other two ESC connected to D6 and D7. When I connected them to D6 I was able to calibrate them. After a long troubleshooting and by connecting the servo to D6, D7 and D8 I was only able to control the servo and ESC connected to port D6. Have concluded that there is something wrong with port D7 and D8.

Do anyone have a solution to my problem? or have experience the same problem?

One possible solution is to try to connect them to the two spare servo/esc ports, D9 and D10. Do anyone know how to change this in the arduino software or in cockpit?

Thanks

Regards

Kjetil


#2

Hi Kjetil:

Make sure when you are calibrating an ESC that you have the other two switched off. If you calibrated D6 successfully, are you sure you switched it off before attempting to calibrate D7? The symptoms you describe are similar to what happens if you leave an ESC on while attempting to calibrate the others.

-W


#3

Thanks for the reply Walt.

I have switch D6 off before calibrating the other ones.

I changed the following in controllerboard25.CPP

Original:

#define VERTICLE_PIN 7

#define STARBORD_PIN 8

New setting:

#define VERTICLE_PIN 9

#define STARBORD_PIN 10

Updated the arduino on the ROV

I then change wires from 7 to 9 and 8 to 10 and I was able to calibrate the ESC withour any problems.

After this there was a few more problems challenges. Unable to control the vertical thruster from cockpit. is able to control it from the calibration picture.

There is no video from the ROV. only a black picture.

Tried to connect the network cable directly into the beaglebone card. Then I got a picture, but the vertical thruster is still not working from the cockpit, only from the calibration window.

My first thought was that there is something wrong with the home adapter. Have any other experienced the same issue?


#4

I don't know what's going on with your vertical thruster.

As to the Homeplug adapter, check that all 3 LEDs are lit on the topside adapter box. If they are, then it is working OK. If not, debug from there.

-W