Cape Problems


#1

Currently i have two openrov capes but i can't seem to get either to work. One of the capes worked initially but after a week it only powered the beagle bone if you only gave it 6 volts instead of 12 and made high pitched sounds. A couple of days later it randomly just stopped powering the beagle bone at all and led3 light doesn't come on even without the beagleboard connected. Basically all it does it does it turn led1 on.

The second one worked until after i connected the ESC and power cycled. This one still powers the beagleboard fine and led1 is lit up. I was thinking it might need a firmware update but when i try to upload it with the webpage or manually with ssh i just get "avrdude: stk500_recv(): programmer is not responding avrdude done. Thank you.".

I was thinking of trying to swap the chip since the other board had the firmware on it and could control the motors, but i would like to know if these boards have any sort of warranty or trouble shooting i can go through to isolating the problematic components.


#2

Hey Mitchell,

Hmmmm... yeah that sounds strange. For the first board, it certainly seems that there is some sort of a hardware issue causing the problems you describe. If the problems persist, and you can't figure out the source, then yeah- I'd say send it back to us and I'll take a look at it for you.

For the second board, we've been having ongoing issues with reprogramming the Capes through the Cockpit interface. If you have an Arduino board laying around, I'd recommend pulling the Atmega328 off the cape, programming it on the Arduino board, then replacing it (be sure to orient it correctly when doing all this). You can also try putting the Atmega328 from your other cape on the new one, but remember that there is a slight risk that if that 328 is the source of the problem with the other cape (like if some of the pins are shorted internally or something like that) it could create the same problem on your second cape. This seems unlikely based on the type of failure you've described, but I figure it doesn't heart to mention it.

Anyway, let us know how it goes, and GOOD LUCK!

Eric


#3

Thanks for the support and it seems i still can't get the board with the voltage problem to work and would like to take you up on your offer. As for the other board i swapped the two Atmega's but it looks like it still has the same problem. I'm not currently in possession of a Arduino or a programmer so i don't really have a fallback but i'm not certain the issue is related to programming now since i had the arduino programmed on the other board. With both Atmega's it just lights up LED1 and it's still detected with "ino serial -p /dev/ttyO1" and outputs the below though.

"picocom v1.4

port is : /dev/ttyO1
flowcontrol : none
baudrate is : 9600
parity is : none
databits are : 8
escape is : C-a
noinit is : no
noreset is : no
nolock is : yes
send_cmd is : ascii_xfr -s -v -l10
receive_cmd is : rz -vv

Terminal ready"


#4

Mitchell, did you ever figure this out?