Cannot SSH into Beaglebone


#1

I am using the openrov 2.7 software and I want to ssh into the beaglebone to update the software from the command line. The issue I am having is if I set my computers ip address to 192.168.254.2 w/ netmask 255.255.255.0 it is unable to connect to the server all together for some reason. The only way it is possible for me to see the cockpit is if I set the ip to automatic and go to 192.168.7.2:8080. With the setting on automatic I am still unable to ssh into 192.168.254.1 or 192.168.7.1. Also, if I go to 192.168.254.2:8080 in the url the webpage is unavailable. Why is my beaglebone on a different ip than the instructions say and why does the connection either get refused or timeout everytime I try to ssh into the beaglebone.


#2

Are you using the USB port on the beaglebone? The reason I ask is that 192.168.7.2 is the default IP address for the beaglebone USB/ethernet adaptor. If you do in fact have the USB connected to your PC, I would double check that you are changing the settings on the correct interface (i.e. LAN not USB). Also, if you are trying to SSH into the beaglebone via the USB port leave your IP as automatic and you will need to connect to 192.168.7.2 (rather than 192.168.7.1 or 192.168.254.1 as you noted).


#3

Have you confirmed that the BBB is actually ON your LAN? You can’t SSH into the thing over the LAN, unless it’s on the LAN. So open the setup admin site for your router and see if it lists a URL for the BBB. On my router (an Asus) I go to 192.168.1.1 and enter the username and password for the admin account. Then I can see a list of attached devices. If your BBB is listed, then use that IP address for an SSH target. I presume it would listed at the first IP you listed, but you need to check. If your router’s subnet mask is 255.255.255.0, then that defines your network. So you’re not likely to see something with an address like 192.168.254.1, because my router masks the first three octets (192.168.1) as the “network,” and only exposes the last octet as a list of host machines on that network. So you need to confirm that your BBB is actually on your network before trying to SSH into the thing.

The other option is what Adam suggested: Connect it to your PC via the USB port, and then SSH in over 192.168.7.2. For example:

$ ssh tb@192.168.7.2

Hope this helps.

TB

EDIT: Maybe I didn’t understand the original problem. I guess I should have started by asking: Have you connected the BBB to your machine directly (either the Ethernet port or via USB), or have you connected it to your LAN via the Ethernet port on the BBB? My answer above was based upon the latter–that you connected the BBB to your local area network. If you instead are connecting the PC and BBB together via an Ethernet connection, then my answer would not apply…because (of course) your router would know nothing about the BBB. So it would be helpful if you could elaborate on how you’re connecting the two devices.