Camera not refreshing?


#1

Hi,

Just getting towards the end of my build. I can get the Rov connected to my browser but the camera image dose not refresh? Any ideas? I can spin the motors, turn the lazers on and move the camera platform up and down. Its just the image that the cockpit starts on dosen’t change.

I’m using a Macbook with a Gigabit ethernet adapter. I havent soldered the tether im just using connecting blocks to test the system.

Any ideas?

Thanks

Ross


#2

Had a couple of minutes spare at lunch time fired up the ROV again. This time using Safari rather than Firefox and the camera worked fine!

But now the game pad isnt showing up a the top of the cockpit. Everything works via the keypad but not the controler…


#3

Be sure to use Chrome, that is what we test and support. We stick to the standard so technically it should work with “any” HTML5 modern browser, but not all browsers actually support the newer standards the same. Feel free to poke around and submit Pull Request for fixes for your favorite browsers and I’m happy to commit them to the code base!


#4

Thanks! Tried it today using Chrome and it worked well… Just need to do leak test and then it should be good to go!