Building blog OROV 2.6 - Armand


#1






Hi fellow ROV'ers!

I'm well into the building of OROV 2.6. So far it has gone fairly well, a few times I've scratched my head, but after all things have gone fairly well up to now.

Just opened the package, lot's of fun awaiting :-)

Assembled the thruster motors and battery tubes.

Assembled the electronics!

Installed the IMU/Depth Card.

Now I just got to figure out the software part...

And let there be light!

Still have some work to do, still waiting for the epoxy to arrive in the mail, but we're getting there :-)

Next step is

-Fine adjust the lasers.

-Configuring S/W for IMU/Depth card.

-Epoxy the end caps and battery modules.

-Try and sort out internal layout inside electronics module, it is a tight fit, and the push from the wires from the 25 pin is pushing the camera hard against the front of the glass. This does the servo no favours since it has to work hard to move the camera tilt.

All the best for now

Armand


#2

Hey Armand!

It's awesome to see the ROV coming along so well!

Here is a GIF I made recently of a 2.6 E-Chassis which may be helpful for figuring out how to organize everything. (note, I later realized that the servo plug wasn't pushed in all the way, but you can ignore that).

Hope this is helpful!

E



#3

Hi Armand,

i had some trouble with the IMU too. In the end i made it working. However, i am not really sure if it works properly at the moment.

I give you a small list of posts and threads which helped me a lot during progress.

most important:

Step 7 in this guide

http://openrov.dozuki.com/Guide/How+to+assemble+the+IMU-Depth+Senso...

the editing of the config file is also described here:

http://openrov.com/profiles/blogs/imu-software-setup-on-2-5-2-6-rov

very important advice from Matthew Valancy in the end of his description

Go back to the OpenROV cockpit and re-upload the arduino code from the

beagle bone.

after that the sensor worked for me and compass appeared in the cockpit plus HUD started moving.

I didnt try this so far:

http://openrov.com/forum/topics/problem-with-imu-depth-module

but it might be helpful during testing the sensor in the field

good luck with the setup of the sensor


#4

192.168.254.1:3131

Hi Tobias and Eric,

Thanks for the input, I was able to load the software for the IMU today. Worked fairly well once I figured out the correct IP address and port to use in Putty: 192.168.254.1:3131

The address is fair enough, but the port required some searching.

Then enabling the "1" in the correct places went fine. Had some trouble exiting and saving the session until I realised I had to press escape to leave edit mode. Was then able to save using the "wq"

Once I had loaded the updated software into the Arduino, OROV booted and came up with compass and depth data among others. Turned out that the little chip inside the epoxy is not 100% aligned with bottom of acrylbase, so it shows a tilt of 6 degrees when flat on table. I guess I need to remove the IMU module and glue it back on with a counteroffset to get it straight.

Calibrated depth in cockpit, still shows about -0.3 meter at surface. I guess I can live with that.

The compass calibration I'm not quite sure how to perform. I have done similar calibration on my diving computer with built in compass, that is done by rotating the compass 360 degrees. Currently the compass does not appear to show correct heading, but is updating when turning the ROV.

With regards to organizing the interior of the electronics module, the problem is partly my own fault, I added a total of 10 wires in spare, so the 25 pin is full. That cramps up the space a bit.

Have bent each wire individually 90 degrees and tried to spread it out more as a flat cable versus a round cable bundle as it originally was. Have also cut the USB cable for the camera and re-soldered it without the excessive cable. Hopefully this will help up with the "claustrophobia" inside the tube.


#5

Hi Armand,

i would not try to remove an glue the sensor again. There must be another opportunity to set the offset. I guess if you remove it you'll destroy it.

I am missing some kind of guide how to calibrate the sensor to. I once pressed the button zero depth and calibrate compass and it seemed as if some calibration was done. Watching at some static html code on the ROV i could see, that the buttons are not linked to something. I am not really sure but i think they do not work at the moment.

to sum up,

my sensor is not showing the right heading at the moment

if i turn it 90° it shows the correct heading seen from the point it was before.

i dont know how to tell the sensor where north is.

Maybe the experts can help :-)


#6

Hi Tobias,

I might have explained myself a bit inaccurate. The plan is not to try to remove the card from inside the epoxy and reglue it. I was more thinking of tilting the hole IMU module a bit to the side compared to the ROV chassis to compensate for the offset.

You may be right about the sensor calibration, it says -0.3 meters whether it is calibrated or not, so the calibration may not do anything at all.

But at least the data is coming in, eventually I'm sure someone more fluent in programming than me will look into the matter.


#7



Ok, so far so good, received the Hysol E-90FL in the mail thanks to Kjetil, who's relatives has been a trip to the US. Potted the endcaps and battery tubes. I also sealed one of the vent holes on one of the end caps, I don't see the point in having two, one should be sufficient.

I also added fuses to the battery power leads, since I experienced that one of them broke off the soldering point on the 25 pin connector. Worst case, short circuiting LiPo batteries could be nasty with fire as a result.

Well, the E-90FL has now cured, and I have done a water test in my bath tub. Worked great, needs some adjusting of ballast, but that's details.

Video of the ordeal can be watched here: http://youtu.be/EFqttUZvzBQ

Testing in a real life environment will follow :-)

100 %

#8

Hi Armand,

did you use the software image 2.5-05? I am always wondering, why me cockpit looks different. The lights brightnessbar is in the very top whereas mine ist still in the sidebar.

Plus the picture is filling the whole freespace. Everything looks cleaner and more usable.

Great work so far.

I stuck at the potting part with my build, because i cant get Hysol 90 - and its hard to find alternatives. And i only have one try i think. ;-)

Tobias


#9

The stress test was nice!!

:-)


#10

Hi Tobias,

Yes, the stress test was a nice touch, although not quite planned for :-)

Software, good question, I used the version that came preloaded in the 2.6 kit which ever that is they ship it with. Have not looked into it yet. Received the kit early February, so presumably it is the latest version from github: https://github.com/OpenROV/openrov-image/blob/master/CHANGELOG.md

See that the latest image is dated 26/28-11-2013, so I guess this is the one I use. Or is there a way to see the revision no in the cockpit? Have not really looked.

Hysol 90: The European Equivalent apparently is Loctite 9489, but that also appears to be a Holy Grail amongst the epoxy alchemists, at least not easy to come by in Norway. I'm sure there are other stuff that will do the trick, but to be the first one to try it is a leap of faith.

Another issue: IMU. As described earlier I connected the IMU/Depth module as per procedure, updated the config file in Putt and uploaded it into the Arduino. After that it worked great once I changed the position of the module, except for the compass data, which was far off by approx. 80 degrees, but was updating. The OROV cockpit gave me associations to flying a F-16 for a moment as I watched the screen flicker with artificial horizons and banking indications as I performed break dance with my Rover.

Next day as I wandered into my little workshop with a cup of coffe and thinking happy thoughts, I cranked up the Rover, suddenly all IMU data was dead as a dudu. All that remains is the depth and temperature data, which still ticks along. I had not done anything to it, it worked like a charm the day before, but now suddenly the IMU part is dead, the cockpit is showing 0 for value for all pitch, yaw, roll and whatever. I tried to upload the Arduino again, but the same disappointing result. If it had been a wiring problem, I would suspect the depth values to be dead as well since it is communicating on a I2C bus. That leaves me with 2 alternatives as far as I can see, either the IMU circuitry on the board has gone to Silicon heaven, or there is something dodgy in the software department. If anyone else has experienced something similar, or have some cunning ideas, feel free to share them here.