Build is finished, However can not get data link lights to work


#1

We have completed our construction and triple checked our wires and wiring on the circuits. Our issue here seems to be no data comms between the home ports. We have power and cable connection lights on both homeports, but no link lights. What voltages should we be seeing on the tether side of the laptop homeport and what should the voltage be at the tether leads on the db25 connector?


#2

Hi James,

Voltage on the Tether should be 5V as it’s powered by USB from your laptop.
Check that your IP adress is set to static with 192.168.254.X where X is something else than 1.


#3

Hi, I am really new at this and in the middle of building. I was able to get the data to work between the home ports by pressing the button on the boards. I validated that I had power from the batteries and PC. There should be 3 green lights in the top side adapter.


#4

We are getting the 5v and can trigger the power on for the rov. The Static ip has been set to 192.168.254.2 yet we are not getting the middle link light on the home ports. Only the cable connection light and the power light are coming on. I did try the resets on the home port with no luck. I should add that we have a yellow triangle on our network adaptor icon in windows. However, I'm thinking that this is because we are not getting a link on the homeports. Perhaps someone could either validate my thinking or correct me.


#5

Ok, here is an update of what we have done. Found starboard battery pack with no voltage. corrected by cleaning neg contacts on one battery. Verified 11.59 volts on both packs at the db25 connector, verified 4.7 volts on both ends of tether. Reimaged sd card, tried new cat 5 cable, verified static ip of 192.168.254.2 via cmd prompt ipconfig command line. No luck with anything.

We do have the 2 middle blue lights on the bb solid after est 1 min start up. on the cape power led is green, d13 is solid and d49 blinks. on the home ports the center link lights are not on, the other two are on. On the bb rj45 plug we have one green and one amber light solid on. we are kind of at a loss here, any and all help is welcome at this point. I have a kid getting really bummed out and frustrated.


#6

Hey James,

This sounds like a tricky one, but let's see if we can figure it out..

To start out, have you tried bypassing the homeplug /tether system altogether by just plugging a regular ethernet cable in between your computer and the BeagleBone on your ROV? If you try that out and it works, that will cut out a lot of other things we'll need to test for.

Also, I'm trying to gather all information possible on what causes these problems and add it to a flow chart that will help people in the future. Here's what I have so far (but I'll try to add hyperlinks to all of the blocks in the future that go to pages for more description for each).

Hopefully we can get to bottom of this soon. Let me know how the test with a regular ethernet cable works out. Good luck!

Eric


#7

Funny you ask that, I just did so before reading your post. So this is what I did, I connected a cable from laptop to bb direct. Left the bb connected to the cape. This bypassing the tether data link. To power the unit I connected the usb portion from the tether. The rov powered up, but still no joy. Using cmd prompt I pinged 192.168.254.1 from 192.168.254.2 and got no response.

Should I try to reformat the SD and run this test again?


#8

Hmmm.... Yeah that should have worked. A few people have reported making a few tries at applying the image before getting their systems to work, so maybe try one more time to format and re-apply the newest 2.5 image to your SD card. You're logging onto 192.168.254.1:8080, right? (I think 192.168.254.1 without the port would still bring up a little "it's working" page, but just thoguht I'd check.)

E


#9

OK, I reformatted and used the same procedures to bypass the data link. It worked this time. Woo hoo!!!!

waiting for the firmware update as I type this. The camera is working, but nothing else at this time. Seems like the firmware update take a bit of time to run.


#10

Yes, we are using the 8080 switch at the end.


#11

Firmware is uploaded via the bypass, cockpit shows camera view but no other data. The lower display bar is blank, except for the capture button. I rebooted resulting in the same effect. I elimated the bypass and used the tethered datalink. Still no comms with the rov. I'm back on the bypass now with only the camera view working. Thoughts?


#12

Okay- seems like two separate issues to me:

1) Firmware not successfully uploaded to the Controller Board

2) Bad comms through the homeplug adapters

For the firmware issue, try doing the update again... (just to check, you're doing this by clicking on Settings in Cockpit and then pressing Upload and Update Firmware, right?) Sometimes this may take a few tries. If the firmware appears to be uploading all the way, but you're still not getting any data from the ROV (and you're not able to control the lights, servo, or motors) then the problem may be more complex (and new) and we'll have to figure it out.

For the comms issues- this may take a little more debugging. Just to clarify- you're getting the two outer lights (power and network) but not the middle light (homeplug) for both the topside and ROV-side homeplug adapter, right?


#13

I concur two separate issues. I just tried to do the firmware update again. The blue update button was not responding. Rebooting the whole system.

The comms issue: yes only the two outer lights are coming on for both datalinks. The center light will flash once during start up, but not on after that point.


#14

reupdated firmware, all controls now working. Still no data on bottom display bar. Done for tonight, diving early in the morning. Catch you later... We are making progress! Thank you Eric for your guidance.

J


#15

Glad to hear it's moving forward! Enjoy your dive tomorrow- we'll get this stuff figured out!

E


#16

James & Eric--

I'm having nearly the exact issues as described in this thread ! And thankfully have made the same progress by following your troubleshooting - finally got the firmware to update, now have control over the motors/camera/lights, but no connectivity through the tether.

One additional problem I've had - the cape board was not getting any power, in a different thread I found reference to 'shorting' J12 on the board - when I do that, it powers up and allows control of everything (now that I have the BB updated). Does it make sense to simply solder that permanently, or should it work without that?

Looking forward to getting the tether working properly and putting the unit in the water! Let me know what ideas you have to try and sort it out.

Thanks,

Todd