Build Day: Notes 2/16/2013


#1

My notes from this weeks build day. Feel free to add or correct...

Water Proofing the motors: Be sure to cover all of the solder with liquid tape. The technique was to use another smaller paint brush, grab a dollop of the liquid tape and cover all of the solder you can see with the first coat. Then add a second coat and while it is liquid go ahead and slide the heat shrink tubing on top of it. I mentioned to Dave that I came across some heat shrink tubing with heat activated adhesive built in that appears to do the same thing with less hassel. Also, this design was not intended to completely prevent the motors from getting damaged over time, they are cheap and the idea was that if they corroded it would not be a big deal to swap them out with new motors.

The big news of course was the follow up on the tether discussion. They got it working and the video was fluid over 350ft of 2 wire tether. May be worth holding off potting the end cap with the cable leads so that you can run the new tether cable... else it will require cutting the existing tether and wire on the new tether using an external water tight connection. Some discussion about running power down the tether but not sure how that will power the ROV yet. If doing this your self, be prepared to create a 3 inch ethernet patch cable to bridge from the powerline network adapter to the beagle bone.




Everyone that is submitting code will need to sign a contributor agreement to keep the project out of hot water regarding I.P.

Keep an eye on the plunger that seals the end caps center... the electronics get wet really quickly when it is missing ;-)

Remember to run everything through the Cockpit browser and ensure the motors are running the right direction before setting everything in the molex connector or you might need to rewire to switch directions. (My note: Seems like that should be a toggle in the software).

Apparently some of the ROVs are freezing after about 5 minutes of runtime and require power cycles to get them to respond again. Just over heard this in passing. I've run mine on bench power for hours with no issues.

More discussions around the servo running past its stop point and that causing the constant noise/drain. There is a patch in one of the other threads from this week that should fix the issue, people had not had a chance to try it yet.

We don't yet have the software setup to record video anywhere yet. No body has taken the project to date. I may take a look this week (kids are out of school... so I've taken some time from work).

More discussions on which battery solution to use. This should be interesting over the next couple weeks with the power over the tether offering some assistance.

The cape has rather robust power regulation, should be able to raise the voltage up well beyond 12V. How high is a question I have, but some other builders thought 19.5V is easily within the range, which is nice because old laptop power supplies at that voltage that can drive 12AMPS are all over my house.


#2

Great recap- thanks, Brian!

E


#3

Just looking at your photo of everything assembled, there's an alternate way of mounting the homeplug adapter. If you have discarded the back case of you webcam, as I have, then it will nest perfectly inside the cape and fit behind the webcam. To ensure it doesn't short on anything, cover the back of the board with kapton or similar insulating tape.


This also allows a much shorter ethernet cable to be used (~60mm)


#4

Brian,

I also had the issue of losing connection to the ROV after 5 minutes. I noticed that this only happened when I connected the ROV directly to a computer (peer-to-peer). When I connected it to my ethernet router, which has a DHCP server for giving dynamic IP addresses to the connected devices, there was no problem at all.

By examining /var/log/syslog at the beaglebone, I found that the ROV was consantly trying to get a dynamic IP address via DHCP. When it was directly connected to my computer, there was no DHCP service, and after almost exacly 5 minutes, the beaglebone gave up looking for a dynamic address and tried to use the IP address it got when it was connected to the router the last time (10.200.100.31). My peer-to-peer connection was using another subnet (192.168.254.x) and so I lost connetion at this point. This happened again and again, almost exactly after 5 minutes of operation.

I solved the problem by changing /etc/network/interfaces at the beaglebone so that it always uses a static IP address, which fits regardless if the ROV is connected to the router or directly to the computer.

-Stefan


#5

I have confirmed the behavior. Can you post the changes you made to /etc/network/interfaces?


#6

Mike, how much have you chopped off the ethernet plug on the Bone? I think here I can see half a plug, enough to give clearance around the tilt servo?

On the detail of the camera usb, you have used a plug/socket as the join, rather than solder the two cut USB ends together?


#7

Yeah, when I crimped it I kinked the wires off to one side so I could remove just over half the plug. You can see it a bit better in this picture:


I just soldered the two cut USB cable ends together, covering each join in heat shrink then a larger piece over the whole join. I need to redo it as the cable is too long and hits the side of the tube if I don't tuck it in carefully.


#8

Per the comment on recording video. For the moment, it seems easiest to connect to the video using VLC which can capture the MJPEG stream and transcode to H.264. As Dom has been working with other solutions for streaming, it seems no more work here is required at the moment. Especially given that network bandwidth is about to open up.

Simply use the VLC Open from Network and point to the stream on the ROV: http://<ipaddr>:8090/?action=stream


#9

Brian,

this is my remaining /etc/network/interfaces configured for only a static IP address:

auto lo
iface lo inet loopback

auto eth0

iface eth0 inet static
name Ethernet alias LAN card
address 10.100.200.19
netmask 255.255.255.0
broadcast 10.100.200.255
network 10.100.200.0
gateway 10.100.200.1

See also: http://askubuntu.com/questions/214170/whats-the-default-etc-network-interfaces

-Stefan


#10

Thx for posting the pics and write-up. -really looking forward to building and using one with my kids.